summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2017-12-18 13:11:05 +0100
committerGuilherme Amadio <amadio@gentoo.org>2017-12-18 14:11:59 +0100
commita1231db2c8164d0fc1359a76e34f1b5f6eb8e18e (patch)
treedb4c4536fa61df9d4a8820271caad6f6fe0e649c /sci-physics
parentsci-physics/root: do not look for Z3, since it's not necessary (diff)
downloadgentoo-a1231db2c8164d0fc1359a76e34f1b5f6eb8e18e.tar.gz
gentoo-a1231db2c8164d0fc1359a76e34f1b5f6eb8e18e.tar.bz2
gentoo-a1231db2c8164d0fc1359a76e34f1b5f6eb8e18e.zip
sci-physics/root: disable unused OCaml bindings
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/files/root-6.12.04-no-ocaml.patch49
-rw-r--r--sci-physics/root/root-6.12.04.ebuild1
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-6.12.04-no-ocaml.patch b/sci-physics/root/files/root-6.12.04-no-ocaml.patch
new file mode 100644
index 00000000000..1d91739f01a
--- /dev/null
+++ b/sci-physics/root/files/root-6.12.04-no-ocaml.patch
@@ -0,0 +1,49 @@
+From 7405b8848e7c0d5ddcaa1f27b905b6931dc262e2 Mon Sep 17 00:00:00 2001
+From: Guilherme Amadio <amadio@cern.ch>
+Date: Mon, 18 Dec 2017 13:08:14 +0100
+Subject: [PATCH] Disable OCaml bindings in LLVM
+
+---
+ interpreter/llvm/src/cmake/config-ix.cmake | 28 ----------------------------
+ 1 file changed, 28 deletions(-)
+
+diff --git a/interpreter/llvm/src/cmake/config-ix.cmake b/interpreter/llvm/src/cmake/config-ix.cmake
+index 6fb589cfd3..d1c9a70d10 100644
+--- a/interpreter/llvm/src/cmake/config-ix.cmake
++++ b/interpreter/llvm/src/cmake/config-ix.cmake
+@@ -575,32 +575,4 @@ if(CMAKE_HOST_APPLE AND APPLE)
+ endif()
+ endif()
+
+-# Keep the version requirements in sync with bindings/ocaml/README.txt.
+-include(FindOCaml)
+-include(AddOCaml)
+-if(WIN32)
+- message(STATUS "OCaml bindings disabled.")
+-else()
+- find_package(OCaml)
+- if( NOT OCAML_FOUND )
+- message(STATUS "OCaml bindings disabled.")
+- else()
+- if( OCAML_VERSION VERSION_LESS "4.00.0" )
+- message(STATUS "OCaml bindings disabled, need OCaml >=4.00.0.")
+- else()
+- find_ocamlfind_package(ctypes VERSION 0.4 OPTIONAL)
+- if( HAVE_OCAML_CTYPES )
+- message(STATUS "OCaml bindings enabled.")
+- find_ocamlfind_package(oUnit VERSION 2 OPTIONAL)
+- set(LLVM_BINDINGS "${LLVM_BINDINGS} ocaml")
+-
+- set(LLVM_OCAML_INSTALL_PATH "${OCAML_STDLIB_PATH}" CACHE STRING
+- "Install directory for LLVM OCaml packages")
+- else()
+- message(STATUS "OCaml bindings disabled, need ctypes >=0.4.")
+- endif()
+- endif()
+- endif()
+-endif()
+-
+ string(REPLACE " " ";" LLVM_BINDINGS_LIST "${LLVM_BINDINGS}")
+--
+2.15.1
+
diff --git a/sci-physics/root/root-6.12.04.ebuild b/sci-physics/root/root-6.12.04.ebuild
index cb4d5d9a4ec..7f21bace306 100644
--- a/sci-physics/root/root-6.12.04.ebuild
+++ b/sci-physics/root/root-6.12.04.ebuild
@@ -129,6 +129,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.32.00-chklib64.patch \
"${FILESDIR}"/${PN}-6.00.01-dotfont.patch \
"${FILESDIR}"/${PN}-6.11.02-hsimple.patch \
+ "${FILESDIR}"/${PN}-6.11.02-no-ocaml.patch \
"${FILESDIR}"/${PN}-6.12.04-z3.patch
# make sure we use system libs and headers