summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-12 09:04:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-12 09:16:46 +0200
commit10b8466f663b78d2dcbbe012310db237c2b8d7ee (patch)
treeff92fa12ab29a10d99ae04e054867e8d9951ee66 /sci-visualization/kst
parentx11-misc/read-edid: EAPI-6 bump (diff)
downloadgentoo-10b8466f663b78d2dcbbe012310db237c2b8d7ee.tar.gz
gentoo-10b8466f663b78d2dcbbe012310db237c2b8d7ee.tar.bz2
gentoo-10b8466f663b78d2dcbbe012310db237c2b8d7ee.zip
sci-visualization/kst: Fix build with Qt-5.11.0_beta3
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-visualization/kst')
-rw-r--r--sci-visualization/kst/files/kst-2.0.8-qt-5.11b3.patch25
-rw-r--r--sci-visualization/kst/kst-2.0.8.ebuild8
2 files changed, 31 insertions, 2 deletions
diff --git a/sci-visualization/kst/files/kst-2.0.8-qt-5.11b3.patch b/sci-visualization/kst/files/kst-2.0.8-qt-5.11b3.patch
new file mode 100644
index 000000000000..b211e1ed21ee
--- /dev/null
+++ b/sci-visualization/kst/files/kst-2.0.8-qt-5.11b3.patch
@@ -0,0 +1,25 @@
+From 91867d80df4fe8f26c9adbfe10c1c883ccb36697 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 12 Jun 2018 08:57:08 +0200
+Subject: [PATCH] Fix configure with Qt-5.11.0_beta3 (no more qt5_use_modules)
+
+---
+ cmake/modules/KstMacros.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/KstMacros.cmake b/cmake/modules/KstMacros.cmake
+index 676d5731..95848f20 100644
+--- a/cmake/modules/KstMacros.cmake
++++ b/cmake/modules/KstMacros.cmake
+@@ -240,7 +240,7 @@ endmacro()
+ macro(kst_link)
+ target_link_libraries(${kst_name} ${ARGV})
+ if(kst_qt5)
+- qt5_use_modules(${kst_name} Widgets Xml Network PrintSupport)
++ target_link_libraries(${kst_name} Qt5::Widgets Qt5::Xml Qt5::Network Qt5::PrintSupport)
+ else()
+ target_link_libraries(${kst_name}
+ ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSVG_LIBRARY} ${QT_QTNETWORK_LIBRARY})
+--
+2.17.1
+
diff --git a/sci-visualization/kst/kst-2.0.8.ebuild b/sci-visualization/kst/kst-2.0.8.ebuild
index 408da47f2984..9d4e9bb326f2 100644
--- a/sci-visualization/kst/kst-2.0.8.ebuild
+++ b/sci-visualization/kst/kst-2.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -40,7 +40,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
DOCS=( AUTHORS README.kstScript )
-PATCHES=( "${FILESDIR}/${P}-includes.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-includes.patch"
+ "${FILESDIR}/${P}-qt-5.11b3.patch"
+)
src_configure() {
local mycmakeargs=(