summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-14 17:24:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 11:12:57 +0100
commit997d6f178125c40168cc5c93e6750f8085e9301b (patch)
tree91e296962b9fea78f54875f83b8a999c0b086401 /sci-visualization/spectromatic/files
parentsci-visualization/xd3d: Removing EAPI 4 ebuild (diff)
downloadgentoo-997d6f178125c40168cc5c93e6750f8085e9301b.tar.gz
gentoo-997d6f178125c40168cc5c93e6750f8085e9301b.tar.bz2
gentoo-997d6f178125c40168cc5c93e6750f8085e9301b.zip
sci-visualization/spectromatic: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3478
Diffstat (limited to 'sci-visualization/spectromatic/files')
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch4
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch4
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch12
3 files changed, 10 insertions, 10 deletions
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
index 48f9d9023358..619aaecf7a89 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
@@ -1,8 +1,8 @@
Respect LDFLAGS, CFLAGS, CC #334715
Fix install paths
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,33 +1,29 @@
# Makefile for spectromatic
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch
index 2d18f01b216a..d7233c1aab81 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch
@@ -1,6 +1,6 @@
diff -ru spectromatic-1.0/spectromatic.c spectromatic-1.0-new/spectromatic.c
---- spectromatic-1.0/spectromatic.c 2002-03-30 06:17:34.000000000 +0100
-+++ spectromatic-1.0-new/spectromatic.c 2004-07-02 21:25:49.485524639 +0200
+--- a/spectromatic.c
++++ b/spectromatic.c
@@ -21,6 +21,7 @@
****************************************************************************/
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch
index edfb7af8c4b3..0c4253e7e765 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch
@@ -1,5 +1,5 @@
---- wave.c.orig 2012-08-06 18:54:21.829756875 -0700
-+++ wave.c 2012-08-06 19:04:35.818049655 -0700
+--- a/wave.c
++++ b/wave.c
@@ -1,11 +1,26 @@
#include <stdio.h>
#include <string.h>
@@ -46,8 +46,8 @@
- printf ("Data Length: %lu\n", header.data_length);
+ printf ("Data Length: %lu\n", (unsigned long)header.data_length);
}
---- wave.h.orig 2012-08-06 18:55:38.009165756 -0700
-+++ wave.h 2012-08-06 18:55:50.377232324 -0700
+--- a/wave.h
++++ b/wave.h
@@ -22,24 +22,25 @@
#ifndef WAVE_H
#define WAVE_H
@@ -90,8 +90,8 @@
int read_header (FILE *f, waveheaderstruct *header);
int read_frames (FILE *f, int start, int length, char *data);
---- spectromatic.c.orig 2012-08-06 18:54:05.260668605 -0700
-+++ spectromatic.c 2012-08-06 19:28:18.637679446 -0700
+--- a/spectromatic.c
++++ b/spectromatic.c
@@ -217,7 +217,7 @@
if (header.modus == 2)
ch2 = (double*) malloc (window_size * sizeof (double));