summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-24 03:15:52 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-24 03:19:50 +0100
commita96b770e4b0eb7888a2c34df51a96757b5fae357 (patch)
treefbeb9a0034fdc04988ec8121b02fa2af6bd8e177 /sci-visualization
parentapp-emulation/wine-staging: Sync with ::wine (diff)
downloadgentoo-a96b770e4b0eb7888a2c34df51a96757b5fae357.tar.gz
gentoo-a96b770e4b0eb7888a2c34df51a96757b5fae357.tar.bz2
gentoo-a96b770e4b0eb7888a2c34df51a96757b5fae357.zip
sci-visualization/gwyddion: Drop Phython (2) support
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.44-r1.ebuild (renamed from sci-visualization/gwyddion/gwyddion-2.44.ebuild)18
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.47-r1.ebuild (renamed from sci-visualization/gwyddion/gwyddion-2.47.ebuild)27
2 files changed, 9 insertions, 36 deletions
diff --git a/sci-visualization/gwyddion/gwyddion-2.44.ebuild b/sci-visualization/gwyddion/gwyddion-2.44-r1.ebuild
index 98103e3b4bb5..47c8b1ba0853 100644
--- a/sci-visualization/gwyddion/gwyddion-2.44.ebuild
+++ b/sci-visualization/gwyddion/gwyddion-2.44-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 )
AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils fdo-mime gnome2-utils python-single-r1
+inherit autotools-utils fdo-mime gnome2-utils
DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
HOMEPAGE="http://gwyddion.net/"
@@ -15,7 +14,7 @@ SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc fits fftw gnome nls opengl perl python ruby sourceview xml X"
+IUSE="doc fits fftw gnome nls opengl perl ruby sourceview xml X"
RDEPEND="
media-libs/libpng:0
@@ -28,10 +27,6 @@ RDEPEND="
gnome? ( gnome-base/gconf:2 )
opengl? ( virtual/opengl x11-libs/gtkglext )
perl? ( dev-lang/perl )
- python? (
- ${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- )
ruby? ( dev-ruby/narray )
sourceview? ( x11-libs/gtksourceview:2.0 )
xml? ( dev-libs/libxml2:2 )"
@@ -45,10 +40,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
MAKEOPTS+=" V=1"
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_configure() {
local myeconfargs=(
--disable-rpath
@@ -58,7 +49,7 @@ src_configure() {
$(use_enable python pygwy)
$(use_enable fits cfitsio)
$(use_with perl)
- $(use_with python)
+ --without-python
$(use_with ruby)
$(use_with fftw fftw3)
$(use_with opengl gl)
@@ -71,7 +62,6 @@ src_configure() {
src_install() {
autotools-utils_src_install
- use python && dodoc modules/pygwy/README.pygwy
}
pkg_postinst() {
diff --git a/sci-visualization/gwyddion/gwyddion-2.47.ebuild b/sci-visualization/gwyddion/gwyddion-2.47-r1.ebuild
index cc4509980eb7..2ae4cecc209b 100644
--- a/sci-visualization/gwyddion/gwyddion-2.47.ebuild
+++ b/sci-visualization/gwyddion/gwyddion-2.47-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit fdo-mime gnome2-utils python-single-r1
+inherit fdo-mime gnome2-utils
DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
HOMEPAGE="http://gwyddion.net/"
@@ -14,7 +12,7 @@ SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc fits fftw gnome nls opengl perl python ruby sourceview xml X"
+IUSE="doc fits fftw gnome nls opengl perl ruby sourceview xml X"
RDEPEND="
media-libs/libpng:0=
@@ -27,10 +25,6 @@ RDEPEND="
gnome? ( gnome-base/gconf:2 )
opengl? ( virtual/opengl x11-libs/gtkglext )
perl? ( dev-lang/perl:= )
- python? (
- ${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- )
ruby? ( dev-ruby/narray )
sourceview? ( x11-libs/gtksourceview:2.0 )
xml? ( dev-libs/libxml2:2 )"
@@ -40,22 +34,16 @@ DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_configure() {
econf \
--disable-rpath \
--without-kde4-thumbnailer \
$(use_enable doc gtk-doc) \
$(use_enable nls) \
- $(use_enable python pygwy) \
+ --disable-pygwy \
$(use_enable fits cfitsio) \
$(use_with perl) \
- $(use_with python) \
+ --without-python \
$(use_with ruby) \
$(use_with fftw fftw3) \
$(use_with opengl gl) \
@@ -64,11 +52,6 @@ src_configure() {
$(use_with X x)
}
-src_install() {
- default
- use python && dodoc modules/pygwy/README.pygwy
-}
-
pkg_postinst() {
use gnome && gnome2_gconf_install
fdo-mime_desktop_database_update