summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-08 11:16:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-08 11:17:54 +0200
commit85999cc21ac3d6cc4266ba0c12094dcc4b9dbabd (patch)
tree5ee052ef9fa1c27bf9488ed2efb84e909e1b6e53 /sys-apps/cpuid
parentgames-puzzle/construo: use correct AR (diff)
downloadgentoo-85999cc21ac3d6cc4266ba0c12094dcc4b9dbabd.tar.gz
gentoo-85999cc21ac3d6cc4266ba0c12094dcc4b9dbabd.tar.bz2
gentoo-85999cc21ac3d6cc4266ba0c12094dcc4b9dbabd.zip
sys-apps/cpuid: move app-arch/gzip to BDEPEND
Closes: https://bugs.gentoo.org/801133 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/cpuid-20201006-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20201006-r1.ebuild b/sys-apps/cpuid/cpuid-20201006-r1.ebuild
new file mode 100644
index 000000000000..6c29a01ce82b
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20201006-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20200203-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}