summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2019-12-22 21:30:33 -0600
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-26 17:59:29 -0800
commit43c2a717e665e94232f46379013706959207c51a (patch)
tree3d6af6c0ddb30b4965a991af9e2449d53ca2b4eb /sys-apps/fd
parentdev-python/ipykernel: do not mangle the python call. (diff)
downloadgentoo-43c2a717e665e94232f46379013706959207c51a.tar.gz
gentoo-43c2a717e665e94232f46379013706959207c51a.tar.bz2
gentoo-43c2a717e665e94232f46379013706959207c51a.zip
eclass/cargo.eclass: specify --path . to install
cargo install has long required --path . for 2018 edition crates but not required it for 2015 edition crates. It is supported however for 2015 edition crates and works for all versions in the tree so it makes sense to make it the default. Added CARGO_INSTALL_PATH as an eclass variable allowing to override the default. Closes: https://bugs.gentoo.org/703590 Signed-off-by: Doug Goldstein <cardoe@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/14097 Tested-by: Georgy Yakovlev <gyakovlev@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/fd')
-rw-r--r--sys-apps/fd/fd-7.3.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/fd/fd-7.3.0-r1.ebuild b/sys-apps/fd/fd-7.3.0-r1.ebuild
index 3afbc07ff760..66ffd10fadf6 100644
--- a/sys-apps/fd/fd-7.3.0-r1.ebuild
+++ b/sys-apps/fd/fd-7.3.0-r1.ebuild
@@ -86,7 +86,7 @@ src_compile() {
}
src_install() {
- cargo_src_install --path=.
+ cargo_src_install
newbashcomp "${T}"/shell_completions/fd.bash fd
insinto /usr/share/zsh/site-functions