summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-30 09:51:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-30 09:51:40 +0200
commit1330ebcc0016cea80b0d41f820c5da4690125415 (patch)
tree8efb9b8fc3f045d3ff385a847bf425ba5912ceb3 /sys-apps/findutils
parentnet-misc/geomyidae: version bump, drop old (diff)
downloadgentoo-1330ebcc0016cea80b0d41f820c5da4690125415.tar.gz
gentoo-1330ebcc0016cea80b0d41f820c5da4690125415.tar.bz2
gentoo-1330ebcc0016cea80b0d41f820c5da4690125415.zip
sys-apps/findutils: Bump to version 4.7.0
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest1
-rw-r--r--sys-apps/findutils/findutils-4.7.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index 5643ce258440..429ddc774744 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1 +1,2 @@
DIST findutils-4.6.0.tar.gz 3780154 BLAKE2B cae93c4e6bac93fa374ffba18ada95b783335fa7f9f9491cdd1848cd9bb6781a98e7b0ae3677c88bb3052afca2e90e066e072ee0f67c407cb7b087b49831d799 SHA512 41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4
+DIST findutils-4.7.0.tar.xz 1895048 BLAKE2B 5d9f1f2f6bc47415057f9139af3d28abae7be9f812a15bce6016a4478eb3206f35c9329f281fda892f614d017f4f5615003ad60b6a74996ebfad81b1f4b54bf0 SHA512 650a24507f8f4ebff83ad28dd27daa4785b4038dcaadc4fe00823b976e848527074cce3f9ec34065b7f037436d2aa6e9ec099bc05d7472c29864ac2c69de7f2e
diff --git a/sys-apps/findutils/findutils-4.7.0.ebuild b/sys-apps/findutils/findutils-4.7.0.ebuild
new file mode 100644
index 000000000000..5d4cd0269a66
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit flag-o-matic toolchain-funcs python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static test"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug 18729
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ program_prefix=$(usex userland_GNU '' g)
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ --program-prefix=${program_prefix}
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}