summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-14 18:08:03 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-14 18:09:45 -0500
commit8ec73ff87f5e8a160372f0b7369a0cc246f76c3d (patch)
tree434b67a801a1a1d10cc4e72c5c5ce9d467a879eb /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
parentsys-libs/libblockdev: add python3.9 (diff)
downloadgentoo-8ec73ff87f5e8a160372f0b7369a0cc246f76c3d.tar.gz
gentoo-8ec73ff87f5e8a160372f0b7369a0cc246f76c3d.tar.bz2
gentoo-8ec73ff87f5e8a160372f0b7369a0cc246f76c3d.zip
sys-apps/gentoo-systemd-integration: bump to v9
Closes: https://bugs.gentoo.org/722096 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
new file mode 100644
index 000000000000..7983540e7260
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}