summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-06 20:31:43 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-06 20:36:40 +0100
commitf4cad940e98c5160cf0bb98825dfbd1205199260 (patch)
tree917a638600bd388feafc431962b09dd0ceb968c5 /sys-apps/gentoo-systemd-integration
parentdev-python/isort-4.3.21_p2: Version bump, add py38, pypy3 (diff)
downloadgentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.tar.gz
gentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.tar.bz2
gentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.zip
sys-apps/gentoo-systemd-integration: Bump to v8
Closes: https://bugs.gentoo.org/651904 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest1
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
index e52c9394062e..16f6be65ab64 100644
--- a/sys-apps/gentoo-systemd-integration/Manifest
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -1 +1,2 @@
DIST gentoo-systemd-integration-7.tar.gz 64243 BLAKE2B 389c6627af6eca9b4a0854d35751a8cb45cdb2795c7b621e96e9d5bcc13a80fe1cb109c0cb2bfd9d33f7642fd08198a0afbd5b4e5956ea6ba8dc89cf4635d9c0 SHA512 cd47caa01d73da57998b6b37d89cbeb53fa722c7f4a31bb03d03762350490cde1db3ce06090df6b6ff25c1cafb40f6c2186efbd52156ebc6d078b4a59d6fef52
+DIST gentoo-systemd-integration-8.tar.bz2 53734 BLAKE2B 711f1f6603fa40e81fe32809a32f61486ab068b1f636502ac36d58e4c204b5f0d46f51a6624f134a457f246b520614213cf45cc5397de769b315e01e32720bcf SHA512 373892ca9ae8845673f9ddad74e0be0b71af944e109adf0d2ce8e54a9c24ffff5e90cfa92e74b7abc1e7d7b1598404258b90b549697bde28a1025a2d974e991f
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
new file mode 100644
index 000000000000..9ad1ea02babe
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}