summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-08 23:14:25 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-08 23:20:26 -0500
commitdd4bad98c06a75c40014621d3be2a9af92a1708c (patch)
treee8e215b6702b555890df3a779f822423911025e7 /sys-apps/groff/groff-1.22.3.ebuild
parentmedia-sound/lilypond: version bump to 2.19.52 (diff)
downloadgentoo-dd4bad98c06a75c40014621d3be2a9af92a1708c.tar.gz
gentoo-dd4bad98c06a75c40014621d3be2a9af92a1708c.tar.bz2
gentoo-dd4bad98c06a75c40014621d3be2a9af92a1708c.zip
sys-apps/groff: handle missing pdf examples #602020
If ghostscript isn't available, groff won't build its pdf examples.
Diffstat (limited to 'sys-apps/groff/groff-1.22.3.ebuild')
-rw-r--r--sys-apps/groff/groff-1.22.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-apps/groff/groff-1.22.3.ebuild b/sys-apps/groff/groff-1.22.3.ebuild
index 712f51ff7945..4007d84cf458 100644
--- a/sys-apps/groff/groff-1.22.3.ebuild
+++ b/sys-apps/groff/groff-1.22.3.ebuild
@@ -75,9 +75,12 @@ src_install() {
dosym tbl /usr/bin/gtbl
if ! use examples ; then
- # Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
- rm -f "${ED}"/usr/share/doc/${PF}/pdf/mom-pdf.pdf
- mv "${ED}"/usr/share/doc/${PF}/{examples/mom,pdf}/mom-pdf.pdf || die
+ # The pdf files might not be generated if ghostscript is unavailable. #602020
+ local pdf="${ED}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
+ if [[ -e ${pdf} ]] ; then
+ # Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
+ mv "${pdf}" "${ED}"/usr/share/doc/${PF}/pdf/ || die
+ fi
rm -rf "${ED}"/usr/share/doc/${PF}/examples
fi
}