summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2019-06-12 17:14:39 -0400
committerJustin Bronder <jsbronder@gentoo.org>2019-06-12 17:16:20 -0400
commitc234db0293d0ffe7b8b9e7e1892c50aa68b19028 (patch)
tree0c2d93bdafba0aa3fd7cb5adbcf8640e5297ed30 /sys-apps/hwloc
parentnet-print/cups-filters: Removed unrecognized configure option (diff)
downloadgentoo-c234db0293d0ffe7b8b9e7e1892c50aa68b19028.tar.gz
gentoo-c234db0293d0ffe7b8b9e7e1892c50aa68b19028.tar.bz2
gentoo-c234db0293d0ffe7b8b9e7e1892c50aa68b19028.zip
Partial Revert "sys-apps/hwloc: cleanup old"
This reverts commit de690876c21341951f7fa9aef5e66c26222862dd as I didn't noticed that arm64 alone had marked 1.11.10 as stable. Signed-off-by: Justin Bronder <jsbronder@gentoo.org>
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/Manifest1
-rw-r--r--sys-apps/hwloc/hwloc-1.11.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/hwloc/Manifest b/sys-apps/hwloc/Manifest
index a0b1ddc50709..8d842bb46d78 100644
--- a/sys-apps/hwloc/Manifest
+++ b/sys-apps/hwloc/Manifest
@@ -1,3 +1,4 @@
+DIST hwloc-1.11.10.tar.bz2 4102431 BLAKE2B 4caec6f1c1a5f0b571854127cc6fd808e778b3b2bcf7ded7edfe99100ac4ccc05c893f3df0a56119234510aa5256e5da84cfa15dddb7d15e49eca2936baa7f41 SHA512 9e2cf5cc43f8c21cfd0bf09a58fda09ba832908eca5a211d164eb106f090609b6351bc934e572200530284fbfc5c460db29a49ec7974dbd298d757ed8aaf32b3
DIST hwloc-1.11.13.tar.bz2 4120436 BLAKE2B a6a09f7d6abeaa9d23df555cfd2186ae61f0f67f83fa8f1aa4bc29376b233a8511f11745f35064f39545c7e62e9d271c1334b6906712028729e138e41d1f212f SHA512 dd38bcc9a5df2dcfd3bbd828ab13fdb1c1d21747a0b62e6c87df95d2835c0472590344ff5bda4f6c28e597eaba1ea11c0bc96907ad45f1215f51f95ac9f58138
DIST hwloc-1.11.2.tar.bz2 4019136 BLAKE2B 29a959c48b3be347b5816333c3f9948ddafc6c4882d7c646c956ae08d72827dd4cef22da7842a034e3131e0044f9528573c6dfceb373869c326890f23651d967 SHA512 aa54b6389c303470a00dbbb3ae5f688244d0f1e0d84e661b739933ff9d86928869f2f3be04fe621cdf06c206defcd4ea1c9e8b72696f7cada9bb3243c3feba68
DIST hwloc-2.0.4.tar.bz2 6057001 BLAKE2B 0d73c2ec544263bb36404d8112412b6b308935b9b8b4ba37cac05d8bdc525763fa862c63d387545cb0e02e1bd8f1c931e034381dede83b7119f30928f4e54bf4 SHA512 c7bb69f0e536188921138d003f3854a12f942a4f625e665d5ce6d32c1c4a884e0a91f9125de33dd292f522032b759e6240df3f3e53534033567ea0d829feefce
diff --git a/sys-apps/hwloc/hwloc-1.11.10.ebuild b/sys-apps/hwloc/hwloc-1.11.10.ebuild
new file mode 100644
index 000000000000..e2f6d1687b8c
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.11.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools cuda flag-o-matic versionator multilib-minimal
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cairo cuda debug gl +numa +pci plugins svg static-libs xml X"
+
+# opencl support dropped with x11-drivers/ati-drivers being removed (#582406).
+# Anyone with hardware is welcome to step up and help test to get it re-added.
+
+# dev-util/nvidia-cuda-toolkit is always multilib
+
+RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
+ cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg?,${MULTILIB_USEDEP}] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1 )
+ gl? ( x11-drivers/nvidia-drivers[static-libs,tools] )
+ pci? (
+ >=sys-apps/pciutils-3.3.0-r2[${MULTILIB_USEDEP}]
+ >=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
+ )
+ plugins? ( dev-libs/libltdl:0[${MULTILIB_USEDEP}] )
+ numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )
+ xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_prepare() {
+ default
+ eautoreconf
+
+ if use cuda ; then
+ append-cflags -I"${EPREFIX}"/opt/cuda/include
+ append-cppflags -I"${EPREFIX}"/opt/cuda/include
+ fi
+}
+
+multilib_src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+
+ if use cuda ; then
+ local -x LDFLAGS="${LDFLAGS}"
+ append-ldflags -L"${EPREFIX}"/opt/cuda/$(get_libdir)
+ fi
+
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static) \
+ $(use_enable cairo) \
+ $(multilib_native_use_enable cuda) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable gl) \
+ $(use_enable pci) \
+ $(use_enable plugins) \
+ $(use_enable numa libnuma) \
+ $(use_enable xml libxml2) \
+ $(use_with X x)
+}