summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-08-19 14:28:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-08-19 14:28:35 -0700
commit27c39af013c9ba5db43cd7f37eabb69b7d076873 (patch)
tree4e9120dd0793cae4d51732f460e11d509ddeec7f /sys-apps/ipmitool
parentdev-haskell/wxc: bump up to 0.92.3.0 (diff)
downloadgentoo-27c39af013c9ba5db43cd7f37eabb69b7d076873.tar.gz
gentoo-27c39af013c9ba5db43cd7f37eabb69b7d076873.tar.bz2
gentoo-27c39af013c9ba5db43cd7f37eabb69b7d076873.zip
sys-apps/ipmitool-1.8.18-r1: Fix build with gcc-10 (bug #706870)
Closes: https://bugs.gentoo.org/706870 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps/ipmitool')
-rw-r--r--sys-apps/ipmitool/files/ipmitool-1.8.18-fno-common.patch22
-rw-r--r--sys-apps/ipmitool/ipmitool-1.8.18-r1.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/ipmitool/files/ipmitool-1.8.18-fno-common.patch b/sys-apps/ipmitool/files/ipmitool-1.8.18-fno-common.patch
new file mode 100644
index 000000000000..5ca554961ca6
--- /dev/null
+++ b/sys-apps/ipmitool/files/ipmitool-1.8.18-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/include/ipmitool/ipmi_hpmfwupg.h
++++ b/include/ipmitool/ipmi_hpmfwupg.h
+@@ -800,8 +800,6 @@
+ char descString[HPMFWUPG_DESC_STRING_LENGTH + 1];
+ }VERSIONINFO, *PVERSIONINFO;
+
+-VERSIONINFO gVersionInfo[HPMFWUPG_COMPONENT_ID_MAX];
+-
+ #define TARGET_VER (0x01)
+ #define ROLLBACK_VER (0x02)
+ #define IMAGE_VER (0x04)
+--- a/lib/ipmi_hpmfwupg.c
++++ b/lib/ipmi_hpmfwupg.c
+@@ -52,6 +52,8 @@
+ # include <config.h>
+ #endif
+
++static VERSIONINFO gVersionInfo[HPMFWUPG_COMPONENT_ID_MAX];
++
+ /* From src/plugins/ipmi_intf.c: */
+ uint16_t
+ ipmi_intf_get_max_request_data_size(struct ipmi_intf * intf);
diff --git a/sys-apps/ipmitool/ipmitool-1.8.18-r1.ebuild b/sys-apps/ipmitool/ipmitool-1.8.18-r1.ebuild
index 9b95f9ff8cef..314005e456a4 100644
--- a/sys-apps/ipmitool/ipmitool-1.8.18-r1.ebuild
+++ b/sys-apps/ipmitool/ipmitool-1.8.18-r1.ebuild
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-openssl-1.1.patch
+ "${FILESDIR}/ipmitool-1.8.18-fno-common.patch"
)
src_prepare() {