summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-25 20:26:35 +0000
committerSam James <sam@gentoo.org>2022-12-25 21:24:09 +0000
commitc1273bba1b1508451060be5e5bad9ac42fcbc7cc (patch)
treeac04ea5e2613fcb54af99945f5dea5a5a1c69b7e /sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild
parentsys-apps/hprofile: add 6.2.1 (diff)
downloadgentoo-c1273bba1b1508451060be5e5bad9ac42fcbc7cc.tar.gz
gentoo-c1273bba1b1508451060be5e5bad9ac42fcbc7cc.tar.bz2
gentoo-c1273bba1b1508451060be5e5bad9ac42fcbc7cc.zip
sys-apps/lcdsplash: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild')
-rw-r--r--sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild b/sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild
new file mode 100644
index 000000000000..b47d14c72f94
--- /dev/null
+++ b/sys-apps/lcdsplash/lcdsplash-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="splash Gentoo boot information on LCD's"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.bz2
+"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="hppa ~mips x86"
+
+RDEPEND="mips? ( sys-apps/lcdutils )"
+
+src_install() {
+ insinto /sbin
+ doins splash-functions.sh
+
+ insinto /$(get_libdir)/rcscripts/lcdsplash
+ doins -r modules/.
+
+ insinto /etc
+ doins lcdsplash.conf
+
+ einstalldocs
+}