summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-12-01 15:48:38 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-12-01 16:17:10 -0600
commit38e69f3759e3753fe58175b42862b9f96de138dd (patch)
treecd76cf268fe9a201c06dd21545cfac9ba945fa65 /sys-apps/opentmpfiles
parentsys-apps/opentmpfiles: install service scripts and block older openrc versions (diff)
downloadgentoo-38e69f3759e3753fe58175b42862b9f96de138dd.tar.gz
gentoo-38e69f3759e3753fe58175b42862b9f96de138dd.tar.bz2
gentoo-38e69f3759e3753fe58175b42862b9f96de138dd.zip
sys-apps/opentmpfiles: 0.1 version bump (initial release)
This code is taken from OpenRC, so I have added the appropriate ~arch keywords. Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/opentmpfiles')
-rw-r--r--sys-apps/opentmpfiles/Manifest1
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/opentmpfiles/Manifest b/sys-apps/opentmpfiles/Manifest
new file mode 100644
index 000000000000..8594bea47dcc
--- /dev/null
+++ b/sys-apps/opentmpfiles/Manifest
@@ -0,0 +1 @@
+DIST opentmpfiles-0.1.tar.gz 5592 SHA256 0c7a52d6394dcbe78dd5b4f8fba6fcc66b207389b9a9b85e61a0ab8e9e375bb7 SHA512 f89e0b996a282ba39f5db7d5cf8e3b72672ba2a9f6013512b7169da9886d9d1d00d4de7c68aefdf2afcf24063283183c37a40864b89d25f68484b022fce58773 WHIRLPOOL 307e6094c0e74ceeb15fe84b09e5ea28b47584eb98a7384b9fa18e66ee7d2c2cc6e574fd2142d6373ff0cf8b302f266a2f277f74d6609d213daf0e92198caba4
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.1.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.1.ebuild
new file mode 100644
index 000000000000..011fa7ac95c8
--- /dev/null
+++ b/sys-apps/opentmpfiles/opentmpfiles-0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/openrc/${PN}"
+else
+ SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
+ ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
+HOMEPAGE="https://github.com/openrc/opentmpfiles"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.23"
+
+src_install() {
+ default
+ cd openrc
+ for f in opentmpfiles-dev opentmpfiles-setup; do
+ newconfd ${f}.confd ${f}
+ newinitd ${f}.initd ${f}
+ done
+}
+
+add_service() {
+ local initd=$1
+ local runlevel=$2
+
+ elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+ ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
+}
+
+pkg_postinst() {
+ add_service opentmpfiles-dev sysinit
+ add_service opentmpfiles-setup boot
+}