summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-09-06 10:16:26 -0700
committerZac Medico <zmedico@gentoo.org>2020-09-06 10:35:20 -0700
commit2af9e69f3462abfcf97679a24897b708f522059e (patch)
treec3e68edafda2ccc6e323a5b4a10c9f54264a0e5a /sys-apps/portage/portage-3.0.4-r1.ebuild
parentdev-python/secretstorage: ppc64 stable (bug #733850) (diff)
downloadgentoo-2af9e69f3462abfcf97679a24897b708f522059e.tar.gz
gentoo-2af9e69f3462abfcf97679a24897b708f522059e.tar.bz2
gentoo-2af9e69f3462abfcf97679a24897b708f522059e.zip
sys-apps/portage: Migrate to tmpfiles eclass
The systemd_dotmpfilesd function is deprecated. Note that this effectively forces upgrade to >=sys-apps/openrc-0.23 for OpenRC users, since opentmpfiles blocks older versions of OpenRC (bug 643386). This should be acceptable, since the older OpenRC versions are nearly 4 years old now. Closes: https://bugs.gentoo.org/740600 Bug: https://bugs.gentoo.org/490676 Bug: https://bugs.gentoo.org/643386 Bug: https://bugs.gentoo.org/740638 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps/portage/portage-3.0.4-r1.ebuild')
-rw-r--r--sys-apps/portage/portage-3.0.4-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-3.0.4-r1.ebuild b/sys-apps/portage/portage-3.0.4-r1.ebuild
index 2cb5d1ea7a9b..9d1c4aea699f 100644
--- a/sys-apps/portage/portage-3.0.4-r1.ebuild
+++ b/sys-apps/portage/portage-3.0.4-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( pypy3 python3_{6..9} )
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 linux-info systemd prefix
+inherit distutils-r1 linux-info tmpfiles prefix
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -217,7 +217,7 @@ python_install_all() {
esetup.py "${targets[@]}"
fi
- systemd_dotmpfilesd "${FILESDIR}"/portage-ccache.conf
+ dotmpfiles "${FILESDIR}"/portage-ccache.conf
# Due to distutils/python-exec limitations
# these must be installed to /usr/bin.