summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-08-25 17:28:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-01 00:12:40 +0200
commitb67cb8871089992d0832fdf6b6c36c60ffd2b5af (patch)
treea382adf64316b9644eea6944f9e5ac3d4cd8f0dd /sys-apps/smc-sum-driver
parentsys-apps/smc-sum: drop old version. (diff)
downloadgentoo-b67cb8871089992d0832fdf6b6c36c60ffd2b5af.tar.gz
gentoo-b67cb8871089992d0832fdf6b6c36c60ffd2b5af.tar.bz2
gentoo-b67cb8871089992d0832fdf6b6c36c60ffd2b5af.zip
sys-apps/smc-sum-driver: update fetch instructions.
Closes: https://bugs.gentoo.org/663666 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-apps/smc-sum-driver')
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r1.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r1.ebuild
new file mode 100644
index 000000000000..825bec7d32ea
--- /dev/null
+++ b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN//-/_}"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN/smc_/}_V${MY_PV}"
+
+DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"/${MY_P}/Linux
+
+BUILD_TARGETS="default"
+MODULE_NAMES="sum_bios(misc:${S})"
+
+pkg_nofetch() {
+ elog "Please contact the Supermicro support at support@supermicro.com,"
+ elog "in order to obtain a copy of ${A}"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ # Install new Makefile to respect users CFLAGS and LDFLAGS
+ cp "${FILESDIR}"/makefile Makefile
+
+ default
+}