summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/syslog-notify/syslog-notify-0.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/syslog-notify/syslog-notify-0.2.ebuild')
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/syslog-notify/syslog-notify-0.2.ebuild b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
new file mode 100644
index 000000000000..6d94ccbd4599
--- /dev/null
+++ b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit readme.gentoo
+
+DESCRIPTION="Notifications for syslog entries via libnotify"
+HOMEPAGE="http://jtniehof.github.com/syslog-notify/"
+SRC_URI="mirror://github/jtniehof/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libnotify-0.7"
+RDEPEND="${DEPEND}
+ || ( app-admin/syslog-ng app-admin/rsyslog )"
+
+pkg_setup() {
+ DOCS="AUTHORS CHANGELOG HACKING README"
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="Add the following options on your /etc/syslog-ng/syslog-ng.conf
+file:
+# destination notify { pipe("/var/spool/syslog-notify"); };
+# log { source(src); destination(notify);};
+
+Remember to restart syslog-ng before starting syslog-notify."
+}
+
+src_install() {
+ default
+ dodir /var/spool
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ mkfifo "${EROOT}"/var/spool/syslog-notify
+ readme.gentoo_print_elog
+}