summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-09-15 14:33:01 +0200
committerPacho Ramos <pacho@gentoo.org>2018-09-15 14:52:22 +0200
commitacfe337d09539ed91c0b34006572ef83c2b7e7b2 (patch)
tree6f0c1d3c7fab2f1d652d707a75a89971161b8b8f /sys-apps/systemd-readahead/systemd-readahead-216.ebuild
parentnet-misc/netpipe: Drop old (diff)
downloadgentoo-acfe337d09539ed91c0b34006572ef83c2b7e7b2.tar.gz
gentoo-acfe337d09539ed91c0b34006572ef83c2b7e7b2.tar.bz2
gentoo-acfe337d09539ed91c0b34006572ef83c2b7e7b2.zip
sys-apps/systemd-readahead: Fix compilation, bug #607068
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-apps/systemd-readahead/systemd-readahead-216.ebuild')
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
index e256882d9165..a7580f0a561f 100644
--- a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -135,8 +135,16 @@ src_configure() {
}
src_compile() {
- echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
- emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > ./Makefile.extra
+ emake -f Makefile -f ./Makefile.extra BUILT_SOURCES
+
+ # Fix compilation, bug #607068
+ # From comments at https://aur.archlinux.org/packages/systemd-readahead
+ gperf < src/libsystemd/sd-bus/bus-error-mapping.gperf > src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/bus_error_mapping_lookup/s/size_t/unsigned int/" src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/lookup_errno/s/size_t/unsigned int/" src/shared/errno-from-name.h || die
+ sed -i -e "/lookup_af/s/size_t/unsigned int/" src/shared/af-from-name.h || die
+ sed -i -e "/lookup_arphrd/s/size_t/unsigned int/" src/shared/arphrd-from-name.h || die
emake systemd-readahead
emake units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer