summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Gupta <manojgupta@google.com>2020-06-09 14:21:59 -0700
committerMike Gilbert <floppym@gentoo.org>2020-06-14 12:08:00 -0400
commit3fb9321eeda5cdfcf6c70138699476b10a1478b8 (patch)
tree54e33ce28c143bb07fcbbc480ec4e12ea58d5e7c /sys-apps/toybox
parentnet-dns/libidn2: Respect portage host cc (diff)
downloadgentoo-3fb9321eeda5cdfcf6c70138699476b10a1478b8.tar.gz
gentoo-3fb9321eeda5cdfcf6c70138699476b10a1478b8.tar.bz2
gentoo-3fb9321eeda5cdfcf6c70138699476b10a1478b8.zip
sys-apps/toybox: Move setting CC/HOST_CC to configure
Move setting up CC/HOST_CC to configure stage. Otherwise emae oldconfig invokes gcc rather than portage specified variables. Signed-off-by: Manoj Gupta <manojgupta@google.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16153
Diffstat (limited to 'sys-apps/toybox')
-rw-r--r--sys-apps/toybox/toybox-0.8.1.ebuild4
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/toybox/toybox-0.8.1.ebuild b/sys-apps/toybox/toybox-0.8.1.ebuild
index 564d2c54b23c..d334e3570448 100644
--- a/sys-apps/toybox/toybox-0.8.1.ebuild
+++ b/sys-apps/toybox/toybox-0.8.1.ebuild
@@ -30,6 +30,8 @@ src_prepare() {
}
src_configure() {
+ tc-export CC STRIP
+ export HOSTCC="$(tc-getBUILD_CC)"
if [ -f .config ]; then
yes "" | emake -j1 oldconfig > /dev/null
return 0
@@ -40,8 +42,6 @@ src_configure() {
}
src_compile() {
- tc-export CC STRIP
- export HOSTCC=$(tc-getBUILD_CC)
unset CROSS_COMPILE
export CPUS=$(makeopts_jobs)
emake V=1
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 722524f40455..68a184db8ebe 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -30,6 +30,8 @@ src_prepare() {
}
src_configure() {
+ tc-export CC STRIP
+ export HOSTCC="$(tc-getBUILD_CC)"
if [ -f .config ]; then
yes "" | emake -j1 oldconfig > /dev/null
return 0
@@ -40,8 +42,6 @@ src_configure() {
}
src_compile() {
- tc-export CC STRIP
- export HOSTCC=$(tc-getBUILD_CC)
unset CROSS_COMPILE
export CPUS=$(makeopts_jobs)
emake V=1