summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-29 14:33:05 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-29 14:33:05 +0200
commitdb365bacbc0122deac04a5add301d2d86c505aab (patch)
treee8bafe1e663fac582103bb7179e83299aa53cb81 /sys-apps/x86info
parentsys-apps/x86info: [QA] Fix various issues (diff)
downloadgentoo-db365bacbc0122deac04a5add301d2d86c505aab.tar.gz
gentoo-db365bacbc0122deac04a5add301d2d86c505aab.tar.bz2
gentoo-db365bacbc0122deac04a5add301d2d86c505aab.zip
sys-apps/x86info: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/Manifest1
-rw-r--r--sys-apps/x86info/files/1.21-pic.patch14
-rw-r--r--sys-apps/x86info/files/x86info-1.24-pic.patch33
-rw-r--r--sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch12
-rw-r--r--sys-apps/x86info/files/x86info-1.30-fix-build-system.patch12
-rw-r--r--sys-apps/x86info/x86info-1.30-r1.ebuild72
-rw-r--r--sys-apps/x86info/x86info-1.30.ebuild72
7 files changed, 0 insertions, 216 deletions
diff --git a/sys-apps/x86info/Manifest b/sys-apps/x86info/Manifest
index 3fa8bb65f0ee..109f35371edd 100644
--- a/sys-apps/x86info/Manifest
+++ b/sys-apps/x86info/Manifest
@@ -1,2 +1 @@
-DIST x86info-1.30.tgz 95727 BLAKE2B 6e9e345c6b4d05d4a137b898f1cc8a31e901b25b8a3822c06c103298e2ee60c6fada8e1fc314a5fcec04618b9a8a9ce05a4e631dbf9f03a24c5349f13d1e2301 SHA512 0b4c9f1be83a737aa26ec14d239d09465608fcf542766ef5b8634d2fe08f75857c0d2bd1969d971ab4b0d55cd3aa3e4e5f58b3b2865865aa68fd751377672e5f
DIST x86info-1.30_p20190617.tar.gz 85913 BLAKE2B e19e5fd797617499c64e75522f0fd030beaa335a6ba9afd29cbb79fd67313a2e57236d1ad8817bf91f0131faf667ba88ac0945ff25301ba8806912979f094ea3 SHA512 352e2b00578dc54b8d5ee32f09f327ab6a23e6ab4743882ca78a5a5ec1a04ceed8780228ffbda34f84ebb02c7cb850002a686929726feac90c8083044f479bd6
diff --git a/sys-apps/x86info/files/1.21-pic.patch b/sys-apps/x86info/files/1.21-pic.patch
deleted file mode 100644
index 7bf89240c2c0..000000000000
--- a/sys-apps/x86info/files/1.21-pic.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/bench/benchmarks.c
-+++ b/bench/benchmarks.c
-@@ -19,7 +19,10 @@
- #ifdef __linux__
- TIME(asm volatile("int $0x80" :"=a" (tmp) :"0" (__NR_getppid)), "int 0x80");
- #endif
-- TIME(asm volatile("cpuid": : :"ax", "dx", "cx", "bx"), "cpuid");
-+ TIME(asm volatile("movl %%ebx,%%edi\n"
-+ "cpuid\n"
-+ "movl %%edi,%%ebx\n"
-+ : : :"%eax", "%edx", "%ecx", "%edi"), "cpuid");
-
- TIME(asm volatile("addl $1,0(%esp)"), "addl");
- TIME(asm volatile("lock ; addl $1,0(%esp)"), "locked add");
diff --git a/sys-apps/x86info/files/x86info-1.24-pic.patch b/sys-apps/x86info/files/x86info-1.24-pic.patch
deleted file mode 100644
index b4098c5c68c2..000000000000
--- a/sys-apps/x86info/files/x86info-1.24-pic.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-http://bugs.gentoo.org/270388
-
---- a/cpuid.c
-+++ b/cpuid.c
-@@ -62,12 +62,28 @@
- sched_setaffinity(getpid(), sizeof(set), &set);
- }
-
-+#ifdef __PIC__
-+ /* GCC on i386 bitches if you clobber ebx. So hide it behind
-+ * gcc's back. */
-+ asm(
-+ "movl %%ebx,%%edi\n"
-+ "cpuid\n"
-+ "movl %%ebx,%1\n"
-+ "movl %%edi,%%ebx\n"
-+ : "=a" (a),
-+ "=m" (b),
-+ "+c" (c),
-+ "=d" (d)
-+ : "0" ((unsigned int)idx)
-+ : "edi");
-+#else
- asm("cpuid"
- : "=a" (a),
- "=b" (b),
- "+c" (c),
- "=d" (d)
- : "0" ((unsigned int)idx));
-+#endif
-
- if (eax!=NULL)
- *eax = a;
diff --git a/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch b/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
deleted file mode 100644
index a9cec0397fac..000000000000
--- a/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -12,7 +12,8 @@
- LSMSR_TMP_HEADERS=AMD/k8.h AMD/fam10h.h AMD/fam11h.h generic_msr.h
-
- %.h: %.regs scripts/createheader.py
-- python scripts/createheader.py $< `basename $< .regs` >$@
-+ $(PYTHON) scripts/createheader.py $< `basename $< .regs` >$@.tmp ; \
-+ mv $@.tmp $@
-
- LSMSR_SRC = \
- lsmsr.c \
diff --git a/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch b/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch
deleted file mode 100644
index 21034d99edc5..000000000000
--- a/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,9 +1,5 @@
- VERSION=1.30
-
--CFLAGS = -g -O2 -Werror -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls
--LDFLAGS = -Wl,-z,relro,-z,now
--CC = gcc
--
- SHELL = /bin/sh
-
- all: x86info test lsmsr
diff --git a/sys-apps/x86info/x86info-1.30-r1.ebuild b/sys-apps/x86info/x86info-1.30-r1.ebuild
deleted file mode 100644
index 5a09ba8a8e78..000000000000
--- a/sys-apps/x86info/x86info-1.30-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4..8} )
-
-inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
-
-DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
-HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
-SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
-RDEPEND="sys-apps/pciutils:="
-DEPEND="
- ${PYTHON_DEPS}
- ${RDEPEND}"
-
-CONFIG_CHECK="~MTRR ~X86_CPUID"
-
-PATCHES=(
- "${FILESDIR}"/1.21-pic.patch
- "${FILESDIR}"/${PN}-1.24-pic.patch #270388
- "${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
- "${FILESDIR}"/${PN}-1.30-fix-build-system.patch
-)
-
-pkg_setup() {
- linux-info_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # These flags taken from the 1.29 ebuild
- append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
- -Wdeclaration-after-statement -Wredundant-decls
- append-ldflags -Wl,-z,relro,-z,now
-
- tc-export CC
-}
-
-src_compile() {
- emake x86info lsmsr
-}
-
-src_install() {
- dobin x86info lsmsr
-
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
-
- einstalldocs
- doman x86info.1 lsmsr.8
-
- dodoc -r results
-}
-
-pkg_preinst() {
- if [[ -a "${EROOT}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info ]]; then
- elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
- mv "${EROOT}"/etc/{modules,modprobe}.d/x86info
- fi
- if [[ -a "${EROOT}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT}"/etc/modprobe.d/x86info.conf ]]; then
- elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
- mv "${EROOT}"/etc/modprobe.d/x86info{,.conf}
- fi
-}
diff --git a/sys-apps/x86info/x86info-1.30.ebuild b/sys-apps/x86info/x86info-1.30.ebuild
deleted file mode 100644
index 358f453ebbbe..000000000000
--- a/sys-apps/x86info/x86info-1.30.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
-
-DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
-HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
-SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-
-RDEPEND="sys-apps/pciutils:="
-DEPEND="
- ${PYTHON_DEPS}
- ${RDEPEND}"
-
-CONFIG_CHECK="~MTRR ~X86_CPUID"
-
-PATCHES=(
- "${FILESDIR}"/1.21-pic.patch
- "${FILESDIR}"/${PN}-1.24-pic.patch #270388
- "${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
- "${FILESDIR}"/${PN}-1.30-fix-build-system.patch
-)
-
-pkg_setup() {
- linux-info_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # These flags taken from the 1.29 ebuild
- append-flags -Wall -Wshadow -Wextra -Wmissing-declarations \
- -Wdeclaration-after-statement -Wredundant-decls
- append-ldflags -Wl,-z,relro,-z,now
-
- tc-export CC
-}
-
-src_compile() {
- emake x86info lsmsr
-}
-
-src_install() {
- dobin x86info lsmsr
-
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
-
- einstalldocs
- doman x86info.1 lsmsr.8
-
- dodoc -r results
-}
-
-pkg_preinst() {
- if [[ -a "${EROOT%/}"/etc/modules.d/x86info ]] && [[ ! -a "${EROOT%/}"/etc/modprobe.d/x86info ]]; then
- elog "Moving x86info from /etc/modules.d/ to /etc/modprobe.d/"
- mv "${EROOT%/}"/etc/{modules,modprobe}.d/x86info
- fi
- if [[ -a "${EROOT%/}"/etc/modprobe.d/x86info ]] && [[ ! -a "${EROOT%/}"/etc/modprobe.d/x86info.conf ]]; then
- elog "Adding .conf suffix to x86info in /etc/modprobe.d/"
- mv "${EROOT%/}"/etc/modprobe.d/x86info{,.conf}
- fi
-}