summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-22 17:09:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-22 18:06:43 +0200
commit7acb8312dd92e2f4c3c837eb638ed0f32fe09296 (patch)
tree4b376044bb9948836509e25a270b88b37b6d79c4 /sys-apps/xdg-desktop-portal
parentprofiles: Mask sys-apps/xdg-desktop-portal[geolocation] b/c masked dep (diff)
downloadgentoo-7acb8312dd92e2f4c3c837eb638ed0f32fe09296.tar.gz
gentoo-7acb8312dd92e2f4c3c837eb638ed0f32fe09296.tar.bz2
gentoo-7acb8312dd92e2f4c3c837eb638ed0f32fe09296.zip
sys-apps/xdg-desktop-portal: 1.4.2 version bump
Closes: https://bugs.gentoo.org/678802 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index cb882d4c980c..7aecea5e798c 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.2.0.tar.xz 405856 BLAKE2B 8d198c7c18b829f531e34d6526b52776a1acffcb874a2ea93953314710aa18bcb1988ffe190bb7b7f7c0d1c4eb1bc3d39fd2f7da626754730bf64f349ae75d39 SHA512 7c7dff8f1f44b4f564f195a8f9ad2985f6085d16638d18941459cd14d76d8ae7cafaf72f461f2c0c1414a8bace9f3ab4a5416de06edb71df677fd7bdca47f61a
+DIST xdg-desktop-portal-1.4.2.tar.xz 421660 BLAKE2B 5395218fa182947c589ff51cd43b838591e47442b23c4fe0719f0970bff3602e81c4f79ad93890bde97a529ca34a733032e85a1f21f41e9aa230d5c2d40e1136 SHA512 9a19dc8f6899a24f8827ce36447316ce74f293abed469be24adfaa16d18deac0b7c5d77f744eed9b540b54cd23145281dacb6811dc52b34180b21d6dc02efc5a
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
new file mode 100644
index 000000000000..dc8410b7de90
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc geolocation"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+DEPEND="
+ dev-libs/glib:2[dbus]
+ sys-fs/fuse:0
+ geolocation? ( app-misc/geoclue:2.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-pipewire
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ )
+ econf "${myeconfargs[@]}"
+}