summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-31 03:11:34 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-31 03:32:59 -0400
commit23a0534045ba68ab395fd445c0e60b95ea0988e4 (patch)
tree1c5de1eb0316845106326b364cabbe0e3764cbf8 /sys-apps
parentdev-util/android-studio: drop old (diff)
downloadgentoo-23a0534045ba68ab395fd445c0e60b95ea0988e4.tar.gz
gentoo-23a0534045ba68ab395fd445c0e60b95ea0988e4.tar.bz2
gentoo-23a0534045ba68ab395fd445c0e60b95ea0988e4.zip
sys-apps/ripgrep: initial import
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ripgrep/Manifest1
-rw-r--r--sys-apps/ripgrep/metadata.xml11
-rw-r--r--sys-apps/ripgrep/ripgrep-0.2.5.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
new file mode 100644
index 000000000000..5c805b92edf0
--- /dev/null
+++ b/sys-apps/ripgrep/Manifest
@@ -0,0 +1 @@
+DIST ripgrep-0.2.5.tar.gz 389606 SHA256 2e535701ed4c36875a29041b4a47629af514182177b82d681a8e4d0fed4a9767 SHA512 c5359ab5120ed355c8e72fded34c311440b357244be6b3950732953b8b6cd558d429e4c6e86737983bdea9118f58e4f26048c4b2374559cf8e14146afcc20fec WHIRLPOOL c5ead5378942cf9f75bd1681e9d18e58704597dc7512c50edfbf3600d326519fa8493fa7d61addef81b19650fdfcd000a5dbfd905f5d50194ad88a062fefe4c4
diff --git a/sys-apps/ripgrep/metadata.xml b/sys-apps/ripgrep/metadata.xml
new file mode 100644
index 000000000000..7cecc57b17f3
--- /dev/null
+++ b/sys-apps/ripgrep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">BurntSushi/ripgrep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/ripgrep/ripgrep-0.2.5.ebuild b/sys-apps/ripgrep/ripgrep-0.2.5.ebuild
new file mode 100644
index 000000000000..bb241f2f41c4
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cargo
+
+DESCRIPTION="a command line search tool that combines usability with raw speed"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-util/cargo"
+
+src_compile() {
+ cargo build --release || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+}