summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-09 13:40:54 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-09 13:43:39 -0700
commit5facaf1701025e7a2622ae242a4a96af2866b620 (patch)
tree89a4c3b6a40fd845a47c9255228d6df8a934ef6f /sys-apps
parentmedia-libs/sdl2-ttf: keyworded 2.0.15 for hppa, bug #727520 (diff)
downloadgentoo-5facaf1701025e7a2622ae242a4a96af2866b620.tar.gz
gentoo-5facaf1701025e7a2622ae242a4a96af2866b620.tar.bz2
gentoo-5facaf1701025e7a2622ae242a4a96af2866b620.zip
sys-apps/opal-utils: bump to 6.6.1
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/opal-utils/Manifest1
-rw-r--r--sys-apps/opal-utils/opal-utils-6.6.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-apps/opal-utils/Manifest b/sys-apps/opal-utils/Manifest
index c0fad88b0484..ead11c802b8d 100644
--- a/sys-apps/opal-utils/Manifest
+++ b/sys-apps/opal-utils/Manifest
@@ -1,2 +1,3 @@
DIST opal-utils-6.5.2.tar.gz 2082426 BLAKE2B 20256f13f95da73bcccae670627c9786229e756183fad33ff45ecf2d91f1039c73a0f881b3ac794abad35d51b7bef0b780bd0f8260818c84a262ce7bb0c45b2e SHA512 765e568ad60f5cd7df8868eb3faea841d37c75cb14f33ab30f9419550ea146aeec0d02d622752af1e09a36e744f93be3a56fe6cbc8ac91a94effba9754a24091
+DIST opal-utils-6.6.1.tar.gz 2121660 BLAKE2B 29ee388e75d86cba346d48834840bde22e6c38404b1dc3544fe7a2c64d584fed95aff8755bcadfba7f3753a764a120d31daa2d8f32e4a4298b65babc44a08193 SHA512 b460de30aa76b1c2bc66b636b995e32abc8554b3a7d8ac5b71401d7f07d999d5b4ca4328a6bbaa9c7c82c237b0e6be5557c9d13f4bbba5c7f625888aaf9cb65e
DIST opal-utils-6.6.tar.gz 2119590 BLAKE2B 3c2b0b77fdaa22f075afe1d7205865b76e45e865c8799372ab61dbd272015ecb1343a32c185d6bd5fb323723a2c5aded1fead2ae0fb34ae6e97e17f5e15af6a6 SHA512 23ae61266253a5382f4d873492e89523cc26a32dfb43438e5becece88f5af4f0bc4ec756208603653f430b3382c42980a8c92dc0c1ba3e2b13831ade1eb14a27
diff --git a/sys-apps/opal-utils/opal-utils-6.6.1.ebuild b/sys-apps/opal-utils/opal-utils-6.6.1.ebuild
new file mode 100644
index 000000000000..d447870f81eb
--- /dev/null
+++ b/sys-apps/opal-utils/opal-utils-6.6.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit linux-info python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="OPAL firmware utilities"
+HOMEPAGE="https://github.com/open-power/skiboot"
+SRC_URI="https://github.com/open-power/skiboot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~ppc64"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="doc? (
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ ')
+)"
+
+CONFIG_CHECK="~MTD_POWERNV_FLASH ~OPAL_PRD ~PPC_DT_CPU_FTRS ~SCOM_DEBUGFS"
+ERROR_MTD_POWERND_FLASH="CONFIG_MTD_POWERND_FLASH is required to use pflash and opal-gard"
+ERROR_OPAL_PRD="CONFIG_OPAL_PRD is required to run opal-prd daemon"
+ERROR_SCOM_DEBUGFS="CONFIG_SCOM_DEBUGFS is required to use xscom-utils"
+
+S="${WORKDIR}/skiboot-${PV}"
+
+python_check_deps() {
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i '/^CFLAGS +=/ s/-g2 -ggdb//' external/opal-prd/Makefile || die
+ sed -i 's/-lrt -o/-lrt $(LDFLAGS) -o/' external/ffspart/rules.mk || die
+}
+
+src_configure() {
+ tc-export CC LD
+ export OPAL_PRD_VERSION="${PV}"
+ export GARD_VERSION="${PV}"
+ export PFLASH_VERSION="${PV}"
+ export XSCOM_VERSION="${PV}"
+ export FFSPART_VERSION="${PV}"
+}
+
+src_compile() {
+ emake V=1 -C external/opal-prd
+ emake V=1 -C external/gard
+ emake V=1 -C external/pflash
+ emake V=1 -C external/xscom-utils
+ emake V=1 -C external/ffspart
+
+ use doc && emake V=1 -C doc html
+}
+
+src_install() {
+ emake -C external/opal-prd DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/gard DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/pflash DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ emake -C external/xscom-utils DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ dosbin external/ffspart/ffspart
+
+ newinitd "${FILESDIR}"/opal-prd.initd opal-prd
+ newconfd "${FILESDIR}"/opal-prd.confd opal-prd
+
+ systemd_dounit external/opal-prd/opal-prd.service
+
+ if use doc; then
+ rm -r doc/_build/html/_sources || die
+ local HTML_DOCS=( doc/_build/html/. )
+ fi
+ einstalldocs
+}
+
+src_test() {
+ emake V=1 -C external/opal-prd test
+ emake V=1 -C external/gard check
+ # this test is fragile and fails because of unstable output
+ rm external/pflash/test/tests/01-info || die
+ emake V=1 -C external/pflash check
+ emake V=1 -C external/ffspart check
+}