summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-04 10:17:56 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-04 10:17:56 -0400
commit7635275fd64e4f8b848eb348eabc9b45bfac36c4 (patch)
tree5ab24221543956793c8e4b77bf10bd4100001ba3 /sys-apps
parentsys-apps/systemd-tmpfiles: include EPREFIX in rootprefix (diff)
downloadgentoo-7635275fd64e4f8b848eb348eabc9b45bfac36c4.tar.gz
gentoo-7635275fd64e4f8b848eb348eabc9b45bfac36c4.tar.bz2
gentoo-7635275fd64e4f8b848eb348eabc9b45bfac36c4.zip
sys-apps/systemd-tmpfiles: add warning for prefix users
Bug: https://bugs.gentoo.org/806794 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
index 04bdfe57698b..82c776afc19e 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
@@ -68,6 +68,12 @@ python_check_deps() {
has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ if [[ -n ${EPREFIX} ]]; then
+ ewarn "systemd-tmpfiles uses un-prefixed paths at runtime.".
+ fi
+}
+
pkg_setup() {
python-any-r1_pkg_setup
}