summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-01-22 17:21:33 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:02 +0000
commit863f3ccf1f0d22549b3259a36177728e70cfecc0 (patch)
treedd57991ae7e16f81fef687baec7e70b25905b50e /sys-apps
parentdev-lang/execline: add myself as a proxy maintainer (diff)
downloadgentoo-863f3ccf1f0d22549b3259a36177728e70cfecc0.tar.gz
gentoo-863f3ccf1f0d22549b3259a36177728e70cfecc0.tar.bz2
gentoo-863f3ccf1f0d22549b3259a36177728e70cfecc0.zip
sys-apps/s6: respect AR, CC and RANLIB
Closes: https://bugs.gentoo.org/747880 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6/s6-2.9.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/s6/s6-2.9.2.0.ebuild b/sys-apps/s6/s6-2.9.2.0.ebuild
index c7ca3e11252d..b5bc32e0f941 100644
--- a/sys-apps/s6/s6-2.9.2.0.ebuild
+++ b/sys-apps/s6/s6-2.9.2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="skarnet.org's small and secure supervision software suite"
HOMEPAGE="https://www.skarnet.org/software/s6/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
@@ -27,9 +29,13 @@ src_prepare() {
# Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
+ tc-export AR CC RANLIB
+
econf \
--bindir=/bin \
--dynlibdir=/usr/$(get_libdir) \