summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-21 00:55:46 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-21 01:29:14 +0200
commitfa01e305bafc92a884afaf94fed95c3feb3deac8 (patch)
tree85c9f7970b3f83dd7d9d05fa27e978e7ac4748e6 /sys-auth/AusweisApp2
parentsys-apps/cpuid: add 20220812 (diff)
downloadgentoo-fa01e305bafc92a884afaf94fed95c3feb3deac8.tar.gz
gentoo-fa01e305bafc92a884afaf94fed95c3feb3deac8.tar.bz2
gentoo-fa01e305bafc92a884afaf94fed95c3feb3deac8.zip
sys-auth/AusweisApp2: add 1.24.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp2')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.24.0.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.24.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.24.0.ebuild
new file mode 100644
index 000000000000..fd2f4d5730d0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.24.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index d9fde2a1de34..3f7d4ec42746 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.22.7.tar.gz 11406133 BLAKE2B 17bc9824035007bf62037562ebd38c2b3558660060c0eba302ac04e8e9d0eabc7c8cb69d064a1a02be213f91f823030e5afdab74d5614db2c1bc8318ca1f9f22 SHA512 4ea1d2c02e076121b340da6d16973de6dafe513d2e9c96b535063466c06137d8e2a325661478d0cfbd96f506a875dca8d4df6a53af657a8d2eb59e7ad7d1a472
+DIST AusweisApp2-1.24.0.tar.gz 11472393 BLAKE2B 84bc4c75aeed01823c6301221898e51bbe31c579993b3e6d6d2e1197f3d53778f4d364e31dc9b71be0217ca15503fa510cce5c47e721cd6e07923d11ca6e2ac2 SHA512 80172f3b2a6cd2d80f991ce4c3825997a23725ae024653a77eca5083f8e2e82943b6f81978b77f6a9e6a99bf055867317bae2090a83555ca944ddbd696be53c3