summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-08-13 16:07:34 +0800
committerJason Zaman <perfinion@gentoo.org>2015-08-13 16:10:46 +0800
commit78b2ef1da0407e74a14ec82803549c34b5ec88eb (patch)
treece56130283c73bbc00900ca22a54eb3b305adf89 /sys-auth/consolekit
parentsys-devel/binutils-config: add an eselect wrapper (diff)
downloadgentoo-78b2ef1da0407e74a14ec82803549c34b5ec88eb.tar.gz
gentoo-78b2ef1da0407e74a14ec82803549c34b5ec88eb.tar.bz2
gentoo-78b2ef1da0407e74a14ec82803549c34b5ec88eb.zip
sys-auth/consolekit: 1.0.0 version bump
Added cgroup to IUSE and deps. updated init script thanks to Lars Wendler Gentoo-Bug: https://bugs.gentoo.org/557356 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/Manifest1
-rw-r--r--sys-auth/consolekit/consolekit-1.0.0.ebuild111
-rw-r--r--sys-auth/consolekit/files/consolekit-1.0.0.initd17
-rw-r--r--sys-auth/consolekit/metadata.xml1
4 files changed, 130 insertions, 0 deletions
diff --git a/sys-auth/consolekit/Manifest b/sys-auth/consolekit/Manifest
index d05c470a18d8..cd51411f5080 100644
--- a/sys-auth/consolekit/Manifest
+++ b/sys-auth/consolekit/Manifest
@@ -1,4 +1,5 @@
DIST ConsoleKit-0.4.6.tar.xz 366572 SHA256 b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c SHA512 54955e3e83778a9216846104da8762fd50a37190e209127dd5d211e2227da617e14f6f5c1359905396d299656e526d14e1187b28eaff7d0ae1d7563dc8d9b46d WHIRLPOOL ebf36b109b4c646d0b874f6b8e2ae9e2d190022ee9b6feff6cbb6b9203c80401c538cc3ca674fa7bde4f07e658d5460864e9784c1e0249d49b4784725a4e05c7
DIST ConsoleKit2-0.9.4.tar.bz2 1184927 SHA256 b3e9554472f1a431576c317536d93ba1ef292916ea8447667deee0b555980e2e SHA512 8bbd04e5d084a4b7d3a9324b21909728d3d358c4fcb7a741f02baa354f8ce5afe2ec1a0613aa140adc754322ad00f2cd57eac8fedc500236a167c356c5a3ae04 WHIRLPOOL f02ebfb8b33c36650d6a57d09200d2d13c48e1b521de6a088399fe2a8af623434f539fa5bd343c720bf0174ab90a8d9d8a2c1a33b8aded0c76367e31b4a1accf
DIST ConsoleKit2-0.9.5.tar.bz2 1250075 SHA256 2a857a304b6792a59f1cd43be51bfb570b06e3659dc71acc59dc1c2ac99fdb42 SHA512 afde7f668088d0b3a78a28ec6d01e00f705b628824e94ae8082dcd6cded24b69ddaf7ccf8c12a2f87bfa60836769d1947209d63bbbbcb17ac668c0c27bf70df5 WHIRLPOOL 80ccc3ff807dae1d3110c1923d1720d4c9ff66e9d8f233af8d6e56c2388088fda9c51279e48e7e81861c8ce9fb7246cfd0bed7c916bd1b86fda4b473c7607f80
+DIST ConsoleKit2-1.0.0.tar.bz2 1288174 SHA256 30b8026e62246593637bacf99ab9cbea18e7fea6ee07c45ae2a351912aacda4b SHA512 311cfc0aa945dcf50b4a98e1b19bd25cef84e89e4d849aa0b4b084b6cd8c52931a3af1c56243af00ff0a27b20230ab126de0cc0f08ea861f12a813399478bafa WHIRLPOOL fa834d0cf22a14844277c9f7333b89596c84368c1803fab119acc7799520a5078487351f23e3a66dd47000e09c447f70c03c2244601faf5236275641eeb3d040
DIST consolekit_0.4.6-4.debian.tar.gz 12192 SHA256 6d4dd5e13a76454b4bab27ab6b407718cd77616afd2b1af7cb8d947c1323b802 SHA512 f7fc5965b1f495d16a8ca167940431bc2569e9bde9e4a356b9c9ed00c2825db61da7b6db3d434d977fff72b3aaef30c455a365b9eba282a887a523753613b58f WHIRLPOOL 961a918c21259e24c68c7a5bf93964825b891ea207c088fecab61f81434012dc8925fca83b74518cfc9cf42f2c4a87eba7518c0829f663716ca0e11e38c856c9
diff --git a/sys-auth/consolekit/consolekit-1.0.0.ebuild b/sys-auth/consolekit/consolekit-1.0.0.ebuild
new file mode 100644
index 000000000000..43253beefee4
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-1.0.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils linux-info pam
+
+MY_PN=ConsoleKit2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats"
+HOMEPAGE="http://github.com/ConsoleKit2/ConsoleKit2 http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${MY_P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_0.4.6-4.debian.tar.gz" # for logrotate file"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="acl cgroups debug doc kernel_linux pam policykit selinux test"
+
+COMMON_DEPEND=">=dev-libs/glib-2.40:2=
+ >=sys-devel/gettext-0.19
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ acl? (
+ sys-apps/acl:=
+ >=virtual/udev-200
+ )
+ cgroups? (
+ app-admin/cgmanager
+ >=sys-libs/libnih-1.0.2[dbus]
+ )
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/polkit-0.110 )"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/coreutils[acl?] )
+ selinux? ( sec-policy/selinux-consolekit )
+ sys-power/pm-utils"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+QA_MULTILIB_PATHS="usr/lib/ConsoleKit/.*"
+
+pkg_setup() {
+ if use kernel_linux; then
+ # This is from http://bugs.gentoo.org/376939
+ use acl && CONFIG_CHECK="~TMPFS_POSIX_ACL"
+ # This is required to get login-session-id string with pam_ck_connector.so
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
+}
+
+src_configure() {
+ econf \
+ XMLTO_FLAGS='--skip-validation' \
+ --libexecdir="${EPREFIX}"/usr/lib/ConsoleKit \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable pam pam-module) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable test docbook-docs) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable acl udev-acl) \
+ $(use_enable cgroups) \
+ $(use_enable test tests) \
+ --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
+ --with-pam-module-dir="$(getpam_mod_dir)" \
+ --with-xinitrc-dir=/etc/X11/xinit/xinitrc.d \
+ --without-systemdsystemunitdir
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dosym /usr/lib/ConsoleKit /usr/lib/${PN}
+
+ dodoc AUTHORS HACKING NEWS README TODO
+
+ newinitd "${FILESDIR}"/${PN}-1.0.0.initd consolekit
+
+ keepdir /usr/lib/ConsoleKit/run-seat.d
+ keepdir /usr/lib/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/log/ConsoleKit
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
+
+ prune_libtool_files --all # --all for pam_ck_connector.la
+
+ rm -rf "${ED}"/var/run || die # let the init script create the directory
+
+ insinto /etc/logrotate.d
+ newins "${WORKDIR}"/debian/${PN}.logrotate ${PN} #374513
+}
diff --git a/sys-auth/consolekit/files/consolekit-1.0.0.initd b/sys-auth/consolekit/files/consolekit-1.0.0.initd
new file mode 100644
index 000000000000..e84a2e0cebc1
--- /dev/null
+++ b/sys-auth/consolekit/files/consolekit-1.0.0.initd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+description="consolekit - tracks login sessions and seats"
+pidfile="/var/run/ConsoleKit/pid"
+command="/usr/sbin/console-kit-daemon"
+
+depend() {
+ need dbus
+ use logger
+}
+
+start_pre() {
+ checkpath -q -d -m 0755 /var/run/ConsoleKit
+}
diff --git a/sys-auth/consolekit/metadata.xml b/sys-auth/consolekit/metadata.xml
index 3eb5156f029d..47e5fd752138 100644
--- a/sys-auth/consolekit/metadata.xml
+++ b/sys-auth/consolekit/metadata.xml
@@ -6,6 +6,7 @@
<email>freedesktop-bugs@gentoo.org</email>
</maintainer>
<use>
+ <flag name="cgroups">Use the kernel to track processes instead of the session cookie.</flag>
<flag name="policykit">Use the PolicyKit framework (<pkg>sys-auth/polkit</pkg>) to get authorization for suspend/shutdown.</flag>
<flag name="systemd-units">Install systemd unit files to replace the modern functionality of logind in <pkg>sys-apps/systemd</pkg>. Not recommended.</flag>
</use>