summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Gutbrod <gentoo@tastytea.de>2019-11-23 02:01:10 +0100
committerCraig Andrews <candrews@gentoo.org>2019-11-24 21:50:52 -0500
commitd1c81e7eac1b85bb927f910f8f594f446b450b6d (patch)
tree2c29cd7f3313a2f4c90ea7902ab5e5565a3cfe1d /sys-auth/google-authenticator
parentsys-auth/google-authenticator: Add Ronny Gudbrod as maintainer. (diff)
downloadgentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.tar.gz
gentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.tar.bz2
gentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.zip
sys-auth/google-authenticator: Version bump 1.06.
Signed-off-by: Ronny Gutbrod <gentoo@tastytea.de> Closes: https://bugs.gentoo.org/699182 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'sys-auth/google-authenticator')
-rw-r--r--sys-auth/google-authenticator/Manifest1
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.06.ebuild52
-rw-r--r--sys-auth/google-authenticator/google-authenticator-9999.ebuild6
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
index 3a1a7a5ac888..761c0d7e8c88 100644
--- a/sys-auth/google-authenticator/Manifest
+++ b/sys-auth/google-authenticator/Manifest
@@ -1 +1,2 @@
DIST google-authenticator-1.05.tar.gz 57778 BLAKE2B c31d7929e2aacffc159ee5384f6f31498585819b848f4f8b026519cf2f2fc566b8533e007844c64d348f1cf423a7175b3221f879c5c1ead360c4f1b3acea57ed SHA512 d97b26c6181dbce0612628484db37b1bf61e984fb2fb3d4974d04038e564404aa17415368dba524f0d17d96ec8d57ae4129b27f0c672d849d16ef03941d87996
+DIST google-authenticator-1.06.tar.gz 62292 BLAKE2B 4eb7d6068a1b824c2299fb8d430b2deb04223690fee74a25c8e917e34200630628c3518a5aecc9fd1537d14d86062dc126191c086464b1c6b3d0207676155dc8 SHA512 a278360be1a3c5a03ddb38d40be45dbba16b6f565ee919377a918565bd8c567ce261890dc10d277edea4f469cf1da1d9cf2c9f3ccfeef8c6887d713c785a5440
diff --git a/sys-auth/google-authenticator/google-authenticator-1.06.ebuild b/sys-auth/google-authenticator/google-authenticator-1.06.ebuild
new file mode 100644
index 000000000000..a087b7c55504
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.06.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}
diff --git a/sys-auth/google-authenticator/google-authenticator-9999.ebuild b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
index 9a5ee8534f92..a087b7c55504 100644
--- a/sys-auth/google-authenticator/google-authenticator-9999.ebuild
+++ b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit autotools multilib
+inherit autotools
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
@@ -24,6 +24,8 @@ IUSE=""
DEPEND="sys-libs/pam"
RDEPEND="${DEPEND}"
+RESTRICT="test"
+
src_prepare() {
default
eautoreconf