summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-11-10 12:04:54 +0000
committerJustin Lecher <jlec@gentoo.org>2018-11-10 13:25:36 +0000
commit00465fcf6c74c73407d7247a915354fd7c0d8cf6 (patch)
treed84cdf32f6853dfc6375f3f579c5942d91a8057c /sys-auth/munge
parentmedia-fonts/noto-emoji: Version bump, provide also the icons (diff)
downloadgentoo-00465fcf6c74c73407d7247a915354fd7c0d8cf6.tar.gz
gentoo-00465fcf6c74c73407d7247a915354fd7c0d8cf6.tar.bz2
gentoo-00465fcf6c74c73407d7247a915354fd7c0d8cf6.zip
sys-auth/munge: Fix munge.key permission problems
Closes: https://bugs.gentoo.org/624962 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-auth/munge')
-rw-r--r--sys-auth/munge/files/munged.initd4
-rw-r--r--sys-auth/munge/munge-0.5.13-r1.ebuild69
2 files changed, 71 insertions, 2 deletions
diff --git a/sys-auth/munge/files/munged.initd b/sys-auth/munge/files/munged.initd
index e028d4ffd166..6bb0a1097f25 100644
--- a/sys-auth/munge/files/munged.initd
+++ b/sys-auth/munge/files/munged.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -25,7 +25,7 @@ start() {
checkpath -d -m 755 -o munge:munge /var/run/munge
checkpath -d -m 711 -o munge:munge /var/lib/munge
checkpath -d -m 700 -o munge:munge /var/log/munge
- checkpath -f -m 640 -o root:munge "${KEYFILE}"
+ checkpath -f -m 600 -o munge:munge "${KEYFILE}"
start-stop-daemon -S /usr/sbin/munged \
--user munge \
--group munge \
diff --git a/sys-auth/munge/munge-0.5.13-r1.ebuild b/sys-auth/munge/munge-0.5.13-r1.ebuild
new file mode 100644
index 000000000000..b84cd36bf18c
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.13-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools user prefix
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="https://github.com/dun/munge"
+SRC_URI="https://github.com/dun/munge/releases/download/munge-${PV}/munge-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gcrypt static-libs"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup munge
+ enewuser munge -1 -1 /var/lib/munge munge
+}
+
+src_prepare() {
+ default
+
+ hprefixify config/x_ac_path_openssl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --with-crypto-lib=$(usex gcrypt libgcrypt openssl) \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ local d
+
+ default
+
+ # 450830
+ if [ -d "${ED}"/var/run ]; then
+ rm -rf "${ED}"/var/run || die
+ fi
+
+ dodir /etc/munge
+
+ for d in "init.d" "default" "sysconfig"; do
+ if [ -d "${ED}"/etc/${d} ]; then
+ rm -r "${ED}"/etc/${d} || die
+ fi
+ done
+
+ newconfd "$(prefixify_ro "${FILESDIR}"/${PN}d.confd)" ${PN}d
+ newinitd "$(prefixify_ro "${FILESDIR}"/${PN}d.initd)" ${PN}d
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}