summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-10-02 15:32:21 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-10-02 15:32:21 -0400
commitd0aed3aad5fc31e0b6865dd8cbad10637f49a385 (patch)
treeccfa3b70b5d0fb407231351bfa6cd8a85dd98461 /sys-auth/ykpers/ykpers-1.19.0.ebuild
parentapp-crypt/yubikey-manager: bump (diff)
downloadgentoo-d0aed3aad5fc31e0b6865dd8cbad10637f49a385.tar.gz
gentoo-d0aed3aad5fc31e0b6865dd8cbad10637f49a385.tar.bz2
gentoo-d0aed3aad5fc31e0b6865dd8cbad10637f49a385.zip
sys-auth/ykpers: bump
required for newer ykman Signed-off-by: Rick Farina <zerochaos@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.19.0.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.19.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.19.0.ebuild b/sys-auth/ykpers/ykpers-1.19.0.ebuild
new file mode 100644
index 000000000000..7bbdcf401e9f
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.19.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ dev-libs/json-c
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+
+ find "${D}" -name '*.la' -delete || die
+}