summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-20 02:40:38 +0000
committerSam James <sam@gentoo.org>2020-10-20 02:40:43 +0000
commit00a599149912784b80e9fa5925c122f3a193aede (patch)
tree5ec2ab9320a76ab4664b27591247df3a359e2e83 /sys-auth
parentdev-python/oslo-messaging: 12.5.1 bump (diff)
downloadgentoo-00a599149912784b80e9fa5925c122f3a193aede.tar.gz
gentoo-00a599149912784b80e9fa5925c122f3a193aede.tar.bz2
gentoo-00a599149912784b80e9fa5925c122f3a193aede.zip
sys-auth/pambase: add 20201020
Includes faillock in minimal case. Bug: https://bugs.gentoo.org/748405 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pambase/Manifest1
-rw-r--r--sys-auth/pambase/pambase-20201020.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/sys-auth/pambase/Manifest b/sys-auth/pambase/Manifest
index 3034bd8f52a3..6b6b0c850b30 100644
--- a/sys-auth/pambase/Manifest
+++ b/sys-auth/pambase/Manifest
@@ -1 +1,2 @@
DIST pambase-20201013.tar.gz 3289 BLAKE2B 81a2216bb5173e5731025e864aa5031b6b4835334a2904c6e9fa2454d01ebb358fcc9d9077b9b122bb2edf4cfda8a5581802537012a423dac6546821184add5d SHA512 b159a86ed7fd0a4c8457625362d9a460bb05e57c63c85be7965dbb2969ef66fa6978b1763fc9b458bb7fe592e4df7b650ec28f52612251c3e6dff1f16ddbaafa
+DIST pambase-20201020.tar.gz 3275 BLAKE2B 8e564eac044bc95fedc24b9ac644d633889dfecf3ed18bf8368e693efdbfd978a90eb1ca96f1f86cbf12a88ac9823db9648a4c4e12888932f622d6b14c7e8395 SHA512 96e0dafdbe5bbfd228c25b393aa08f91a208af0cbf6fcf2e5351ef540b6b95eb63d0d342c1e33bd30ee5a705c87251fa732432c2d29edd3c74b2cba0a3d43acc
diff --git a/sys-auth/pambase/pambase-20201020.ebuild b/sys-auth/pambase/pambase-20201020.ebuild
new file mode 100644
index 000000000000..89cb1cd2318d
--- /dev/null
+++ b/sys-auth/pambase/pambase-20201020.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit pam python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="PAM base configuration files"
+HOMEPAGE="https://github.com/gentoo/pambase"
+SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="caps debug elogind gnome-keyring minimal mktemp +nullok pam_krb5 pam_ssh +passwdqc pwhistory pwquality securetty selinux +sha512 systemd"
+
+RESTRICT="binchecks"
+
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ ?? ( passwdqc pwquality )
+ pwhistory? ( || ( passwdqc pwquality ) )
+"
+
+MIN_PAM_REQ=1.4.0
+
+RDEPEND="
+ >=sys-libs/pam-${MIN_PAM_REQ}
+ elogind? ( sys-auth/elogind[pam] )
+ gnome-keyring? ( gnome-base/gnome-keyring[pam] )
+ mktemp? ( sys-auth/pam_mktemp )
+ pam_krb5? (
+ >=sys-libs/pam-${MIN_PAM_REQ}
+ sys-auth/pam_krb5
+ )
+ caps? ( sys-libs/libcap[pam] )
+ pam_ssh? ( sys-auth/pam_ssh )
+ passwdqc? ( >=sys-auth/passwdqc-1.4.0-r1 )
+ pwquality? ( dev-libs/libpwquality[pam] )
+ selinux? ( sys-libs/pam[selinux] )
+ sha512? ( >=sys-libs/pam-${MIN_PAM_REQ} )
+ systemd? ( sys-apps/systemd[pam] )
+"
+
+BDEPEND="$(python_gen_any_dep '
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')"
+
+python_check_deps() {
+ has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ ${EPYTHON} ./${PN}.py \
+ $(usex caps '--libcap' '') \
+ $(usex debug '--debug' '') \
+ $(usex elogind '--elogind' '') \
+ $(usex gnome-keyring '--gnome-keyring' '') \
+ $(usex minimal '--minimal' '') \
+ $(usex mktemp '--mktemp' '') \
+ $(usex nullok '--nullok' '') \
+ $(usex pam_krb5 '--krb5' '') \
+ $(usex pam_ssh '--pam-ssh' '') \
+ $(usex passwdqc '--passwdqc' '') \
+ $(usex pwhistory '--pwhistory' '') \
+ $(usex pwquality '--pwquality' '') \
+ $(usex securetty '--securetty' '') \
+ $(usex selinux '--selinux' '') \
+ $(usex sha512 '--sha512' '') \
+ $(usex systemd '--systemd' '')
+}
+
+src_test() { :; }
+
+src_install() {
+ local DOC_CONTENTS
+
+ if use passwdqc; then
+ DOC_CONTENTS="To amend the existing password policy please see the man 5 passwdqc.conf
+ page and then edit the /etc/security/passwdqc.conf file"
+ fi
+
+ if use pwquality; then
+ DOC_CONTENTS="To amend the existing password policy please see the man 5 pwquality.conf
+ page and then edit the /etc/security/pwquality.conf file"
+ fi
+
+ { use passwdqc || use pwquality; } && readme.gentoo_create_doc
+
+ dopamd -r stack/.
+}
+
+pkg_postinst() {
+ { use passwdqc || use pwquality; } && readme.gentoo_print_elog
+}