summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-13 15:32:53 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:37 +0000
commit5d2982b0e0e30d8caa74281cb61d25521726f819 (patch)
tree2b217dd4c52c91eacee146286ae80b190cc801c7 /sys-auth
parentdev-libs/npth: fix build with lld-16 (diff)
downloadgentoo-5d2982b0e0e30d8caa74281cb61d25521726f819.tar.gz
gentoo-5d2982b0e0e30d8caa74281cb61d25521726f819.tar.bz2
gentoo-5d2982b0e0e30d8caa74281cb61d25521726f819.zip
sys-auth/passwdqc: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild15
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.2-r1.ebuild15
2 files changed, 26 insertions, 4 deletions
diff --git a/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild b/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
index abb50e927b18..90ea5b5ec52c 100644
--- a/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
+++ b/sys-auth/passwdqc/passwdqc-1.4.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit pam toolchain-funcs
+inherit flag-o-matic pam toolchain-funcs
DESCRIPTION="Password strength checking library (and PAM module)"
HOMEPAGE="http://www.openwall.com/passwdqc/"
@@ -40,6 +40,17 @@ src_prepare() {
}
+src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
+ default
+}
+
_emake() {
emake \
SHARED_LIBDIR="/usr/$(get_libdir)" \
diff --git a/sys-auth/passwdqc/passwdqc-2.0.2-r1.ebuild b/sys-auth/passwdqc/passwdqc-2.0.2-r1.ebuild
index a81c6b2a6942..2710ce4c24dc 100644
--- a/sys-auth/passwdqc/passwdqc-2.0.2-r1.ebuild
+++ b/sys-auth/passwdqc/passwdqc-2.0.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit pam toolchain-funcs
+inherit flag-o-matic pam toolchain-funcs
DESCRIPTION="Password strength checking library (and PAM module)"
HOMEPAGE="http://www.openwall.com/passwdqc/"
@@ -40,6 +40,17 @@ src_prepare() {
}
+src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
+ default
+}
+
_emake() {
emake \
SHARED_LIBDIR="/usr/$(get_libdir)" \