summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-04-21 08:05:40 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-04-21 08:09:11 -0700
commitf2d465249bb54366d84f6c4c9689dbc6cc5cc80f (patch)
tree5981f85cb691c35fbe5802dd260fc019215a2cab /sys-block/blktrace/blktrace-1.3.0-r1.ebuild
parentdev-python/sphinx: Bump to 7.3.7 (diff)
downloadgentoo-f2d465249bb54366d84f6c4c9689dbc6cc5cc80f.tar.gz
gentoo-f2d465249bb54366d84f6c4c9689dbc6cc5cc80f.tar.bz2
gentoo-f2d465249bb54366d84f6c4c9689dbc6cc5cc80f.zip
sys-block/blktrace: QA direct cc call
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/930357
Diffstat (limited to 'sys-block/blktrace/blktrace-1.3.0-r1.ebuild')
-rw-r--r--sys-block/blktrace/blktrace-1.3.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-block/blktrace/blktrace-1.3.0-r1.ebuild b/sys-block/blktrace/blktrace-1.3.0-r1.ebuild
index f894d58430b3..9f6d161916e2 100644
--- a/sys-block/blktrace/blktrace-1.3.0-r1.ebuild
+++ b/sys-block/blktrace/blktrace-1.3.0-r1.ebuild
@@ -32,12 +32,13 @@ src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
if use doc; then
export VARTEXFONTS="${T}/fonts"
- emake docs
+ emake docs CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
fi
}
src_install() {
- emake install DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
+ # Do not remove the CC/FLAGS here; bug 930357
+ emake install DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
einstalldocs
use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
}