summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-12 14:18:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-12 14:21:42 +0200
commit9d4bc57aab6fd50f629922b3e5bd0ea39082d745 (patch)
tree750674adcbddcda6cc44e56433e0ba55e63779b8 /sys-block/di
parentnew version + autotools patch (diff)
downloadgentoo-9d4bc57aab6fd50f629922b3e5bd0ea39082d745.tar.gz
gentoo-9d4bc57aab6fd50f629922b3e5bd0ea39082d745.tar.bz2
gentoo-9d4bc57aab6fd50f629922b3e5bd0ea39082d745.zip
sys-block/di: Bump to version 4.46
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-block/di')
-rw-r--r--sys-block/di/Manifest1
-rw-r--r--sys-block/di/di-4.46.ebuild39
-rw-r--r--sys-block/di/files/di-4.46-no_echo-n.patch278
3 files changed, 318 insertions, 0 deletions
diff --git a/sys-block/di/Manifest b/sys-block/di/Manifest
index 61992986a175..e722326542b8 100644
--- a/sys-block/di/Manifest
+++ b/sys-block/di/Manifest
@@ -1,3 +1,4 @@
DIST di-4.43.tar.gz 267160 BLAKE2B c8e56e07d82df21eb839e97ee1d20ca76530ad3485888523faffdf0ad79941b35da41fde83645b58a747c1b40882fe68838255d081bc5fa32d9a3dd4846b43a8 SHA512 5b84c2ebf6fa22f6c7fee5872cc81a76e897cadbdaf8ce1b1b8dac0d53d5460127c8144f94fad204bdc522117cd1fcbac2905a065057d83b8aed0d69a5b95f9a
DIST di-4.44.tar.gz 267509 BLAKE2B 0dd84906a1e710db9868c15cbc3334976469206d44d302a4ec31bad05cbc43643acd1076f0c12a22c9d642e21c6a9a03d6359db62902da5814bba73a346fae3d SHA512 e4d04def74ee1d9349daa8f01519243833135d63220678b3841505ba2d4667d1d5ec81a09e891bf1abb5e0016fc9cb6e674292665d0d29af7371160ff6eced5c
DIST di-4.45.tar.gz 213282 BLAKE2B aafeed268940a9680e21cdbf6b3b21c7636d6638f35347be8389af7654fa993839c85845468ba7cb44bacc63a71efe9db36dcf9bea8fb4ef03a91f04d93c13c3 SHA512 f66fbc69f984b3a3bebbec935f583fb1ad84e33265ebb2734486f784459604071d9ec1639fa0edec5a4b48397f465656d40570f42d10fa0ef50dea17ed9cdd75
+DIST di-4.46.tar.gz 217096 BLAKE2B 4757dec7d9c0da121d0057e8088ecb5994f60eec8de49db4a12e84a68d2ad9dc86462f01370786e0c03a792f39984aead2d838d34b4881396aacb39386635bfd SHA512 ead1172dfa9db74d6a8378f8ded460b365c0445d75d71154c67446585d63c0824f8fdc4818438b3d9c3c4795af518f1499c29762712fd62ab97e9be7e680d133
diff --git a/sys-block/di/di-4.46.ebuild b/sys-block/di/di-4.46.ebuild
new file mode 100644
index 000000000000..c84517d06767
--- /dev/null
+++ b/sys-block/di/di-4.46.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RESTRICT="test" #405205, #405471
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.33-build.patch
+ "${FILESDIR}"/${PN}-4.46-no_echo-n.patch
+)
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)" NLS=$(usex nls T F)
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}
diff --git a/sys-block/di/files/di-4.46-no_echo-n.patch b/sys-block/di/files/di-4.46-no_echo-n.patch
new file mode 100644
index 000000000000..1b78c6c9ebe1
--- /dev/null
+++ b/sys-block/di/files/di-4.46-no_echo-n.patch
@@ -0,0 +1,278 @@
+Neither "echo -n" nor "echo ... \c" is POSIX compliant.
+
+See "man 1p echo" section "APPLICATION USAGE" or
+https://www.in-ulm.de/%7Emascheck/various/echo+printf/
+
+--- di-4.46/C/tests.d/rpmbuild.sh
++++ di-4.46/C/tests.d/rpmbuild.sh
+@@ -12,13 +12,13 @@
+ locatecmd locrpmbuild rpmbuild
+
+ if [ "${locrpmbuild}" = "" ];then
+- echo ${EN} " skipped${EC}" >&5
++ printf '%s' " skipped" >&5
+ exit 0
+ fi
+
+ rvers=`rpmbuild --version | tr -cd '0-9' | sed 's/^\(...\).*/\1/'`
+ if [ $rvers -lt 470 ]; then
+- echo ${EN} " old version skipped${EC}" >&5
++ printf '%s' " old version skipped" >&5
+ exit 0
+ fi
+
+--- di-4.46/mkconfig/bin/shellfuncs.sh
++++ di-4.46/mkconfig/bin/shellfuncs.sh
+@@ -28,17 +28,6 @@
+ echo "mkconfig version ${_MKCONFIG_VERSION}"
+ }
+
+-setechovars () {
+- EN='-n'
+- EC=''
+- if [ "`echo -n test`" = "-n test" ]; then
+- EN=''
+- EC='\c'
+- fi
+- export EN
+- export EC
+-}
+-
+ dosubst () {
+ subvar=$1
+ shift
+--- di-4.46/mkconfig/bin/testfuncs.sh
++++ di-4.46/mkconfig/bin/testfuncs.sh
+@@ -19,14 +19,14 @@
+
+ chkccompiler () {
+ if [ "${CC}" = "" ]; then
+- echo ${EN} " no C compiler; skipped${EC}" >&5
++ printf '%s' " no C compiler; skipped" >&5
+ exit 0
+ fi
+ }
+
+ chkdcompiler () {
+ if [ "${DC}" = "" ]; then
+- echo ${EN} " no D compiler; skipped${EC}" >&5
++ printf '%s' " no D compiler; skipped" >&5
+ exit 0
+ fi
+ }
+--- di-4.46/mkconfig/mkconfig.sh
++++ di-4.46/mkconfig/mkconfig.sh
+@@ -28,7 +28,6 @@
+ . ${_MKCONFIG_DIR}/bin/shellfuncs.sh
+
+ doshelltest $0 $@
+-setechovars
+
+ LOG="mkconfig.log"
+ _MKCONFIG_TMP="_tmp_mkconfig"
+@@ -154,7 +153,7 @@
+ tlabel=$2
+
+ echo " $ifleveldisp[${tname}] ${tlabel} ... " >&9
+- echo ${EN} "${ifleveldisp}${tlabel} ... ${EC}" >&1
++ printf '%s' "${ifleveldisp}${tlabel} ... " >&1
+ }
+
+ _doexport () {
+--- di-4.46/mkconfig/mkc.sh
++++ di-4.46/mkconfig/mkc.sh
+@@ -16,7 +16,6 @@
+ . ${_MKCONFIG_DIR}/bin/shellfuncs.sh
+
+ doshelltest $0 $@
+-setechovars
+
+ rc=0
+ args=$@
+--- di-4.46/mkconfig/runtests.sh
++++ di-4.46/mkconfig/runtests.sh
+@@ -136,8 +136,8 @@
+ systype=`uname -s`
+ shelllist=""
+ for s in $tshelllist; do
+- echo ${EN} " check $s${EC}" >&8
+- echo ${EN} " $s${EC}"
++ printf '%s' " check $s" >&8
++ printf '%s' " $s"
+ cmd="$s -c \". $_MKCONFIG_DIR/bin/shellfuncs.sh;chkshell echo\""
+ eval $cmd >&8 2>&1
+ rc=$?
+@@ -177,7 +177,7 @@
+
+ cd $_MKCONFIG_TSTRUNTMPDIR
+ if [ "$_MKCONFIG_SHELL" != "" ]; then
+- echo ${EN} " ${dispshell}${EC}"
++ printf '%s' " ${dispshell}"
+ fi
+ targ=$arg
+ if [ "$arg" != "" ]; then
+@@ -195,7 +195,7 @@
+ echo "####" >&9
+ exec 9>&-
+ if [ $rc -ne 0 -a "$_MKCONFIG_SHELL" != "" ]; then
+- echo ${EN} "*${EC}"
++ printf '%s' "*"
+ fi
+ return $rc
+ }
+@@ -225,7 +225,6 @@
+
+ doshelltest $0 $@
+ if [ $SUBDIR = F ]; then
+- setechovars
+ mkconfigversion
+ fi
+
+@@ -386,8 +385,8 @@
+ arg="mkconfig.sh"
+
+ scount=""
+- echo ${EN} "$tbase ...${EC}"
+- echo ${EN} "$tbase ...${EC}" >&8
++ printf '%s' "$tbase ..."
++ printf '%s' "$tbase ..." >&8
+ _MKCONFIG_TSTRUNTMPDIR=$_MKCONFIG_RUNTMPDIR/${tbase}
+ export _MKCONFIG_TSTRUNTMPDIR
+ mkdir ${_MKCONFIG_TSTRUNTMPDIR}
+@@ -395,14 +394,14 @@
+ cp $tconfig $_MKCONFIG_TSTRUNTMPDIR/$tconfh
+ fi
+ tfdisp=`$_MKCONFIG_RUNTESTDIR/$tf -d`
+- echo ${EN} " ${tfdisp}${EC}"
+- echo ${EN} " ${tfdisp}${EC}" >&8
++ printf '%s' " ${tfdisp}"
++ printf '%s' " ${tfdisp}" >&8
+ $_MKCONFIG_RUNTESTDIR/$tf -q
+ runshpl=$?
+
+ if [ $runshpl -eq $_MKC_SH -o $runshpl -eq $_MKC_SH_PL ]; then
+- echo ${EN} " ...${EC}"
+- echo ${EN} " ...${EC}" >&8
++ printf '%s' " ..."
++ printf '%s' " ..." >&8
+ src=0
+ scount=1
+ for s in $shelllist; do
+@@ -468,12 +467,12 @@
+ echo "# Test: $tf mkconfig.pl" >&9
+ echo "# $dt" >&9
+ echo "####" >&9
+- echo ${EN} "$tbase ...${EC}"
+- echo ${EN} "$tbase ...${EC}" >&8
+- echo ${EN} " ${tfdisp}${EC}"
+- echo ${EN} " ${tfdisp}${EC}" >&8
+- echo ${EN} " ... perl${EC}"
+- echo ${EN} " ... perl${EC}" >&8
++ printf '%s' "$tbase ..."
++ printf '%s' "$tbase ..." >&8
++ printf '%s' " ${tfdisp}"
++ printf '%s' " ${tfdisp}" >&8
++ printf '%s' " ... perl"
++ printf '%s' " ... perl" >&8
+ echo "## Using mkconfig.pl " >&9
+ if [ -f $tconfig ]; then
+ cp $tconfig $_MKCONFIG_TSTRUNTMPDIR/$tconfh
+--- di-4.46/mkconfig/units/c-main.sh
++++ di-4.46/mkconfig/units/c-main.sh
+@@ -559,7 +559,7 @@
+ eval $cmd
+ echo "## dcl(C): ${dcl}" >&9
+ c=`echo ${dcl} | sed 's/[^,]*//g'`
+- ccount=`echo ${EN} "$c${EC}" | wc -c`
++ ccount=`printf '%s' "$c" | wc -c`
+ domath ccount "$ccount + 1" # 0==1 also, unfortunately
+ c=`echo ${dcl} | sed 's/^[^(]*(//'`
+ c=`echo ${c} | sed 's/)[^)]*$//'`
+--- di-4.46/mkconfig/units/d-main.sh
++++ di-4.46/mkconfig/units/d-main.sh
+@@ -1680,7 +1680,7 @@
+ echo "## tdcl(D): ${tdcl}" >&9
+ if [ $argflag = 1 ]; then
+ c=`echo ${tdcl} | sed 's/[^,]*//g'`
+- ccount=`echo ${EN} "$c${EC}" | wc -c`
++ ccount=`printf '%s' "$c" | wc -c`
+ domath ccount "$ccount + 1" # 0==1 also, unfortunately
+ c=`echo ${tdcl} | sed 's/^[^(]*(//'`
+ c=`echo ${c} | sed 's/)[^)]*$//'`
+--- di-4.46/tests.d/buildsh.sh
++++ di-4.46/tests.d/buildsh.sh
+@@ -43,7 +43,7 @@
+ fi
+ fi
+
+- echo ${EN} " ${d}${EC}" >&5
++ printf '%s' " ${d}" >&5
+ ${MAKE:-make} ${TMAKEFLAGS} realclean
+ ${MAKE:-make} ${TMAKEFLAGS} -e prefix=${instdir} all > make.log 2>&1
+ rc=$?
+--- di-4.46/tests.d/diarg.sh
++++ di-4.46/tests.d/diarg.sh
+@@ -93,7 +93,7 @@
+ tdir=$_MKCONFIG_RUNTOPDIR/$d
+
+ if [ -x ${tdir}/di ]; then
+- echo ${EN} " ${d}${EC}" >&5
++ printf '%s' " ${d}" >&5
+ # most all unix
+ ${tdir}/di -n -f M / 2>/dev/null | grep '^/[ ]*$' > /dev/null 2>&1
+ rc=$?
+@@ -135,7 +135,7 @@
+ done
+
+ if [ $lrc -ne 0 ]; then
+- echo ${EN} "*${EC}" >&5
++ printf '%s' "*" >&5
+ grc=1
+ fi
+ else
+--- di-4.46/tests.d/disort.sh
++++ di-4.46/tests.d/disort.sh
+@@ -41,7 +41,7 @@
+ fi
+ )
+ if [ -x $tdir/di ]; then
+- echo ${EN} " ${d}${EC}" >&5
++ printf '%s' " ${d}" >&5
+ echo "## regular sort first, then di sort"
+ echo "by special"
+ ${tdir}/di -n -a -f S | sort > s1
+@@ -118,12 +118,12 @@
+
+ rm -f s1 s2
+ if [ $grc -ne 0 ]; then
+- echo ${EN} "*${EC}" >&5
++ printf '%s' "*" >&5
+ fi
+ else
+ if [ $d = C ]; then
+ echo "## no di executable found for dir $d"
+- echo ${EN} "*${EC}" >&5
++ printf '%s' "*" >&5
+ grc=1
+ fi
+ fi
+--- di-4.46/tests.d/ditot.sh
++++ di-4.46/tests.d/ditot.sh
+@@ -27,7 +27,7 @@
+ fi
+ )
+ if [ -x ${tdir}/di ]; then
+- echo ${EN} " ${d}${EC}" >&5
++ printf '%s' " ${d}" >&5
+ for format in $FORMATS; do
+ echo "Checking format: $format"
+ # have to exclude zfs, null (dragonflybsd)
+@@ -37,7 +37,7 @@
+ didata=`${tdir}/di -n -d1 -f $format -t -a -x null,zfs,ctfs,objfs,sharefs 2>/dev/null `
+ summtot=`(echo "0 ";echo $didata | sed 's/ */ + /g'; echo " - p") | dc`
+ if [ $summtot -ne 0 ]; then
+- echo ${EN} "*${EC}" >&5
++ printf '%s' "*" >&5
+ echo "## format: $format failed"
+ grc=1
+ fi