summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-01-22 13:02:09 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-01-22 13:03:44 -0800
commit8e1ed2776ca3509bea3627f3c66ac6b99cef7119 (patch)
treec2fc5ed2a34432d9174f72e73ad08c5eb6ff728c /sys-block/fio/fio-2.2.9.ebuild
parentdev-libs/go-fuse: Use egit_clean to clean workdir (diff)
downloadgentoo-8e1ed2776ca3509bea3627f3c66ac6b99cef7119.tar.gz
gentoo-8e1ed2776ca3509bea3627f3c66ac6b99cef7119.tar.bz2
gentoo-8e1ed2776ca3509bea3627f3c66ac6b99cef7119.zip
sys-block/fio: Version bump & bug #572446.
- Version bump. - Fix bug #572446: USE=static builds, the deps need to be build with USE=static-libs, or else the build will fail (backported change to last stable as well, as also affected). X-Gentoo-Bug: 572446 Package-Manager: portage-2.2.24 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-block/fio/fio-2.2.9.ebuild')
-rw-r--r--sys-block/fio/fio-2.2.9.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-block/fio/fio-2.2.9.ebuild b/sys-block/fio/fio-2.2.9.ebuild
index 8f3560078ce6..7010f30399c9 100644
--- a/sys-block/fio/fio-2.2.9.ebuild
+++ b/sys-block/fio/fio-2.2.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,15 +18,17 @@ SLOT="0"
KEYWORDS="amd64 arm ia64 ppc ppc64 x86"
IUSE="aio glusterfs gnuplot gtk numa rbd rdma static zlib"
-DEPEND="aio? ( dev-libs/libaio )
- glusterfs? ( sys-cluster/glusterfs )
+# GTK+:2 does not offer static libaries
+# numactl always includes static libraries
+DEPEND="aio? ( static? ( dev-libs/libaio[static-libs(+)] ) !static? ( dev-libs/libaio ) )
+ glusterfs? ( static? ( sys-cluster/glusterfs[static-libs(+)] ) !static? ( sys-cluster/glusterfs ) )
gtk? (
- dev-libs/glib:2
+ static? ( dev-libs/glib:2[static-libs(+)] ) !static? ( dev-libs/glib:2 )
x11-libs/gtk+:2
)
numa? ( sys-process/numactl )
- rbd? ( sys-cluster/ceph )
- zlib? ( sys-libs/zlib )"
+ rbd? ( static? ( sys-cluster/ceph[static-libs(+)] ) !static? ( sys-cluster/ceph ) )
+ zlib? ( static? ( sys-libs/zlib[static-libs(+)] ) !static? ( sys-libs/zlib ) )"
RDEPEND="${DEPEND}
gnuplot? (
sci-visualization/gnuplot