summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-12-26 13:52:14 +0100
committerPacho Ramos <pacho@gentoo.org>2017-12-26 13:53:02 +0100
commitde6cdf76e3813b4cf1e916f28c1a8ad2cf9d190e (patch)
treef941034677df51328f1b942e7707aa5a111d9356 /sys-boot/os-prober
parentdev-lang/ghc: bump up to 8.4.1_alpha1 (unkeyworded) (diff)
downloadgentoo-de6cdf76e3813b4cf1e916f28c1a8ad2cf9d190e.tar.gz
gentoo-de6cdf76e3813b4cf1e916f28c1a8ad2cf9d190e.tar.bz2
gentoo-de6cdf76e3813b4cf1e916f28c1a8ad2cf9d190e.zip
sys-boot/os-prober: grub-mount is needed (#607518), support Exherbo (#518658)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/files/os-prober-1.76-exherbo.patch26
-rw-r--r--sys-boot/os-prober/os-prober-1.76-r1.ebuild86
2 files changed, 112 insertions, 0 deletions
diff --git a/sys-boot/os-prober/files/os-prober-1.76-exherbo.patch b/sys-boot/os-prober/files/os-prober-1.76-exherbo.patch
new file mode 100644
index 000000000000..6ef83dca223f
--- /dev/null
+++ b/sys-boot/os-prober/files/os-prober-1.76-exherbo.patch
@@ -0,0 +1,26 @@
+From 09fefdb360b69c2de03a2f1c881db87f924d3c76 Mon Sep 17 00:00:00 2001
+From: Timo Gurr <timo.gurr@gmail.com>
+Date: Mon, 20 Feb 2017 17:33:14 +0100
+Subject: [PATCH] Add Exherbo Linux detection
+
+---
+ os-probes/mounted/common/90linux-distro | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/os-probes/mounted/common/90linux-distro b/os-probes/mounted/common/90linux-distro
+index badfbb1..41a5553 100755
+--- a/os-probes/mounted/common/90linux-distro
++++ b/os-probes/mounted/common/90linux-distro
+@@ -137,6 +137,9 @@ if (ls "$dir"/lib*/ld*.so* && [ -d "$dir/boot" ] || ls "$dir"/usr/lib*/ld*.so*)
+ elif [ -e "$dir/etc/devuan_version" ]; then
+ short="Devuan"
+ long="$(printf "Devuan GNU/Linux (%s)\n" "$(cat "$dir/etc/devuan_version")")"
++ elif [ -e "$dir/etc/exherbo-release" ]; then
++ short="Exherbo"
++ long="Exherbo Linux"
+ else
+ short="Linux"
+ long="unknown Linux distribution"
+--
+2.11.1
+
diff --git a/sys-boot/os-prober/os-prober-1.76-r1.ebuild b/sys-boot/os-prober/os-prober-1.76-r1.ebuild
new file mode 100644
index 000000000000..1baceb5af895
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.76-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="https://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# grub-mount needed per bug #607518
+RDEPEND="sys-boot/grub:2[mount]"
+DEPEND=""
+
+# bug 594250
+QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.76-exherbo.patch )
+
+DOC_CONTENTS="
+ If you intend for os-prober to detect versions of Windows installed on
+ NTFS-formatted partitions, your system must be capable of reading the
+ NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g
+"
+
+src_prepare() {
+ default
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ if [[ -d $dir/$debarch/efi ]]; then
+ exeinto /usr/lib/$dir/efi
+ doexe $dir/$debarch/efi/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ einstalldocs
+ dodoc debian/changelog
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}