summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-23 14:12:06 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-23 14:12:06 +0200
commit7224a68f2bd6ddc65bd36b0bd7761626971bb9c1 (patch)
tree31231a9797aa1ef998cbf2754deb585351b9dc96 /sys-boot/unetbootin/unetbootin-657.ebuild
parentsys-firmware/intel-microcode: drop old (diff)
downloadgentoo-7224a68f2bd6ddc65bd36b0bd7761626971bb9c1.tar.gz
gentoo-7224a68f2bd6ddc65bd36b0bd7761626971bb9c1.tar.bz2
gentoo-7224a68f2bd6ddc65bd36b0bd7761626971bb9c1.zip
sys-boot/unetbootin: Old.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-boot/unetbootin/unetbootin-657.ebuild')
-rw-r--r--sys-boot/unetbootin/unetbootin-657.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/sys-boot/unetbootin/unetbootin-657.ebuild b/sys-boot/unetbootin/unetbootin-657.ebuild
deleted file mode 100644
index f675b358ca6b..000000000000
--- a/sys-boot/unetbootin/unetbootin-657.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils qmake-utils
-
-DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
-HOMEPAGE="https://github.com/unetbootin/unetbootin"
-SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} l10n_${lingua/_/-}"
-done
-
-S=${WORKDIR}/${P}/src/${PN}
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="
- ${DEPEND}
- app-arch/p7zip
- sys-boot/syslinux
- sys-fs/mtools
-"
-PATCHES=(
- "${FILESDIR}/${PN}-581-desktop.patch"
-)
-
-src_prepare() {
- default
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use l10n_${lingua/_/-}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- sed -i -e '/^RESOURCES/d' unetbootin.pro || die
-
- UNBN_QTPATH="$(qt4_get_bindir)/"
- "${UNBN_QTPATH}"lrelease ${PN}.pro || die
-
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use l10n_${lingua/_/-}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}