summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-02-22 16:28:58 +0100
committerPacho Ramos <pacho@gentoo.org>2020-02-22 16:28:58 +0100
commit7618d42499b9f1236bb432ef738c6688e255497f (patch)
tree13eff264bf46f39c29174b6d719d63d204d5c34d /sys-boot/woeusb/woeusb-3.3.1.ebuild
parentnet-misc/rygel: drop unnecessary virtualx inherit (diff)
downloadgentoo-7618d42499b9f1236bb432ef738c6688e255497f.tar.gz
gentoo-7618d42499b9f1236bb432ef738c6688e255497f.tar.bz2
gentoo-7618d42499b9f1236bb432ef738c6688e255497f.zip
sys-boot/woeusb: Bump to 3.3.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-boot/woeusb/woeusb-3.3.1.ebuild')
-rw-r--r--sys-boot/woeusb/woeusb-3.3.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-boot/woeusb/woeusb-3.3.1.ebuild b/sys-boot/woeusb/woeusb-3.3.1.ebuild
new file mode 100644
index 000000000000..2828715f8b07
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-3.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/slacka/WoeUSB"
+SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+ sys-boot/grub:2[grub_platforms_pc]
+ !minimal? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
+ if ! use minimal; then
+ setup-wxwidgets
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ ! use minimal && default
+}
+
+src_compile() {
+ ! use minimal && default
+}
+
+src_test() {
+ ! use minimal && default
+}
+
+src_install() {
+ if use minimal; then
+ dosbin src/woeusb
+ einstalldocs
+ else
+ default
+ fi
+}