summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2019-10-21 03:35:55 -0400
committerJoshua Kinard <kumba@gentoo.org>2019-10-21 03:37:00 -0400
commit41c8d5466a5ee5eda57360a4f9d82b6efcca21d9 (patch)
tree3e5f30cdb127e34faca97b7c52fbba43999e2b42 /sys-boot
parentx11-misc/xnots: Clean up patch (diff)
downloadgentoo-41c8d5466a5ee5eda57360a4f9d82b6efcca21d9.tar.gz
gentoo-41c8d5466a5ee5eda57360a4f9d82b6efcca21d9.tar.bz2
gentoo-41c8d5466a5ee5eda57360a4f9d82b6efcca21d9.zip
sys-boot/colo: Use EAPI=6 and fix minor gcc build issue
Resolves Bug #697184 Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-2.3.77, Repoman-2.3.17
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/colo-1.22.ebuild10
-rw-r--r--sys-boot/colo/files/colo-stage2_src_heap-fix.patch24
2 files changed, 29 insertions, 5 deletions
diff --git a/sys-boot/colo/colo-1.22.ebuild b/sys-boot/colo/colo-1.22.ebuild
index 36d8c6e08464..d18a3506ac89 100644
--- a/sys-boot/colo/colo-1.22.ebuild
+++ b/sys-boot/colo/colo-1.22.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
+EAPI=6
inherit eutils toolchain-funcs
DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
@@ -16,8 +15,9 @@ DEPEND=""
RDEPEND=""
RESTRICT="strip"
-src_unpack() {
- unpack ${A}
+src_prepare() {
+ epatch "${FILESDIR}"/colo-stage2_src_heap-fix.patch
+ default
}
src_compile() {
diff --git a/sys-boot/colo/files/colo-stage2_src_heap-fix.patch b/sys-boot/colo/files/colo-stage2_src_heap-fix.patch
new file mode 100644
index 000000000000..6cd4e3a2a226
--- /dev/null
+++ b/sys-boot/colo/files/colo-stage2_src_heap-fix.patch
@@ -0,0 +1,24 @@
+diff -Naurp colo-1.22.orig/stage2/src/heap.c colo-1.22/stage2/src/heap.c
+--- colo-1.22.orig/stage2/src/heap.c 2006-01-22 10:26:56.000000000 -0500
++++ colo-1.22/stage2/src/heap.c 2019-10-20 23:20:17.167266445 -0400
+@@ -25,16 +25,16 @@ static size_t next_size;
+ void heap_reset(void)
+ {
+ extern char __text;
+- void *restrict;
++ void *restrict2;
+
+ assert(!((unsigned long) &__text & 15));
+
+ free_lo = KSEG0(0);
+ free_hi = KSEG0(&__text) - (32 << 10); // XXX
+
+- restrict = KSEG0(ram_restrict) - (16 << 10); // XXX
+- if(free_hi > restrict)
+- free_hi = restrict;
++ restrict2 = KSEG0(ram_restrict) - (16 << 10); // XXX
++ if(free_hi > restrict2)
++ free_hi = restrict2;
+
+ image_size = 0;
+ image_size_mark = 0;