summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-14 15:07:51 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-14 15:08:03 -0800
commitab70393b8cadaf5f477a0df4b189a7e8e3a4c7da (patch)
tree068604543db8096afc689987170bc18c27fa08c1 /sys-boot
parentsys-cluster/kubectl: Initial version (diff)
downloadgentoo-ab70393b8cadaf5f477a0df4b189a7e8e3a4c7da.tar.gz
gentoo-ab70393b8cadaf5f477a0df4b189a7e8e3a4c7da.tar.bz2
gentoo-ab70393b8cadaf5f477a0df4b189a7e8e3a4c7da.zip
sys-boot/grub: update test dependencies.
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-9999.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 7409bfd4ffef..8aeed5fc3425 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -95,8 +95,14 @@ DEPEND="${RDEPEND}
)
)
test? (
- dev-libs/libisoburn
+ app-admin/genromfs
+ app-arch/cpio
+ app-arch/lzop
app-emulation/qemu
+ dev-libs/libisoburn
+ sys-apps/miscfiles
+ sys-block/parted
+ sys-fs/squashfs-tools
)
themes? (
app-arch/unzip
@@ -137,6 +143,14 @@ src_prepare() {
sed -i -e 's/^\* GRUB:/* GRUB2:/' -e 's/(grub)/(grub2)/' docs/grub.texi || die
fi
+ # Nothing in Gentoo packages 'american-english' in the exact path
+ # wanted for the test, but all that is needed is a compressible text
+ # file, and we do have 'words' from miscfiles in the same path.
+ sed -i \
+ -e '/CFILESSRC.*=/s,american-english,words,' \
+ tests/util/grub-fs-tester.in \
+ || die
+
if [[ -n ${GRUB_AUTOGEN} ]]; then
python_setup
bash autogen.sh || die