summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Rothenpieler <btbn@btbn.de>2020-07-24 21:34:00 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-10-21 14:58:09 +0200
commite50ae9c2a0231556f783652e6951e49222744bd0 (patch)
tree9a62e2c55e36cc3e453f8e666e0ab4515f20bfb5 /sys-cluster/corosync
parentsys-cluster/kronosnet: add new corosync dependency (diff)
downloadgentoo-e50ae9c2a0231556f783652e6951e49222744bd0.tar.gz
gentoo-e50ae9c2a0231556f783652e6951e49222744bd0.tar.bz2
gentoo-e50ae9c2a0231556f783652e6951e49222744bd0.zip
sys-cluster/corosync: bump for 3.0.4
Bug: https://bugs.gentoo.org/658354 Signed-off-by: Timo Rothenpieler <btbn@btbn.de> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/Manifest1
-rw-r--r--sys-cluster/corosync/corosync-3.0.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-cluster/corosync/Manifest b/sys-cluster/corosync/Manifest
index 93243a9c3494..f5b0f6e764ad 100644
--- a/sys-cluster/corosync/Manifest
+++ b/sys-cluster/corosync/Manifest
@@ -1,2 +1,3 @@
DIST corosync-2.3.5.tar.gz 428253 BLAKE2B be9fc2b27b60357acee6dee013bc95c08045c114acafc62eaa82a1821f07ff76b8821b9d06f31246b9978f8aef46e3a9e1a2d61ca74465bc74d4140c0ad0d0fa SHA512 212a95d8a68a2941f27c9ec22750a88598744d6fd4db6b46abe0b4cdfa988d3906f760bdf67c403d8c6d0a04da64f29ec744fb68ca51c7269ba58e306553cee9
DIST corosync-2.4.2.tar.gz 547204 BLAKE2B 1b440e84b25263ea866bd66f9837a3bdbbc790d26a38d10a033d67bb0ba48dd58d6b515879dd0ece75ffe78c8a150c1e5ab8d0eb312e701abdc36eb5cb4dc520 SHA512 45a4d2570d5d096e6f42070f701fdb2aaed26812b6a75f73ea415cf409b33343f8bc090b4fcf851ab971ca4b17925f239c31a3d9eafe4841dfbeb56537b2c78c
+DIST corosync-3.0.4.tar.gz 437582 BLAKE2B a37a3d1543943a76bfff2a11ea62c6fc1dfef3bb7c18fe946c7417d68a4122a6ed13035b0342b65bf1a3f8f8fb4536926b4a9864c8a3c5726f9fde32ab4fca0a SHA512 5ff2e4905d309d25a35aaf3df8081b5bc76eac25b526118e833b5e7af7b440f9d84804352cd283f3c46342e8cb337e460e06d53e58c4302c940405c76e64ade7
diff --git a/sys-cluster/corosync/corosync-3.0.4.ebuild b/sys-cluster/corosync/corosync-3.0.4.ebuild
new file mode 100644
index 000000000000..82dcdda380bb
--- /dev/null
+++ b/sys-cluster/corosync/corosync-3.0.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc systemd xml dbus"
+
+# TODO: support those new configure flags
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-watchdog : Watchdog support
+RDEPEND="dev-libs/nss
+ >=sys-cluster/libqb-2.0.0:=
+ sys-cluster/kronosnet:=
+ dbus? ( sys-apps/dbus )
+ systemd? ( sys-apps/systemd:= )
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+DOCS=( README.recovery AUTHORS )
+
+src_prepare() {
+ default
+
+ sed -i 's/$SEC_FLAGS $OPT_CFLAGS $GDB_FLAGS/$OS_CFLAGS/' configure.ac || die 'sed failed'
+
+ if ! use doc; then
+ sed -i 's/BUILD_HTML_DOCS, test/BUILD_HTML_DOCS, false/' configure.ac || die 'sed failed'
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf_opts=(
+ --disable-static \
+ --localstatedir=/var \
+ $(use_enable dbus) \
+ $(use_enable systemd) \
+ $(use_enable xml xmlconf)
+ )
+ use doc && econf_opts+=( --enable-doc )
+ econf "${econf_opts[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync /var/log/cluster
+
+ find "${D}" -name '*.la' -delete || die
+}