summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-01-11 10:03:28 -0500
committerManuel Rüger <mrueg@gentoo.org>2019-01-14 15:33:58 +0100
commit5853d927bfeaa19de0843b7c73a17144d123e0fa (patch)
treea19d4a5c41c50fb8bddaaabbdb00c98dcec918c6 /sys-cluster/kubeadm
parentmedia-libs/phonon-vlc: amd64 stable wrt bug #674860 (diff)
downloadgentoo-5853d927bfeaa19de0843b7c73a17144d123e0fa.tar.gz
gentoo-5853d927bfeaa19de0843b7c73a17144d123e0fa.tar.bz2
gentoo-5853d927bfeaa19de0843b7c73a17144d123e0fa.zip
sys-cluster/kubeadm: New Package
kubeadm is the new stable tool for standing up kubernetes clusters. It reached general availability in 1.13.0 and is positioned to become the go to tool to bootstap kuberentes clusters. Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-cluster/kubeadm')
-rw-r--r--sys-cluster/kubeadm/Manifest1
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.13.2.ebuild47
-rw-r--r--sys-cluster/kubeadm/metadata.xml30
3 files changed, 78 insertions, 0 deletions
diff --git a/sys-cluster/kubeadm/Manifest b/sys-cluster/kubeadm/Manifest
new file mode 100644
index 000000000000..5ecce56fc15b
--- /dev/null
+++ b/sys-cluster/kubeadm/Manifest
@@ -0,0 +1 @@
+DIST kubernetes-1.13.2.tar.gz 28771642 BLAKE2B 4a5c5a8e0c05faab3fb6a26854e7c8643b893c2a1f5d5b56aacea869d86426dffe358222034b826d66dfd19855bee71cad7356ff483c27218019e4adda499ce7 SHA512 2f24119fc21d7bdbb60174b46da94ce3f2f6a3c638e9d96323c93c20039aeb06f9c9a3a48c43bb36b71eff25cf72967e780e3339b35ad7ad7a7a7c35662c96bd
diff --git a/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild b/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild
new file mode 100644
index 000000000000..6c4b699b7594
--- /dev/null
+++ b/sys-cluster/kubeadm/kubeadm-1.13.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11
+ dev-go/go-bindata"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+ pushd src/${EGO_PN} || die
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ popd || die
+}
diff --git a/sys-cluster/kubeadm/metadata.xml b/sys-cluster/kubeadm/metadata.xml
new file mode 100644
index 000000000000..c1a4c8210661
--- /dev/null
+++ b/sys-cluster/kubeadm/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dan@danmolik.com</email>
+ <name>Dan Molik</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ kubeadm performs the actions necessary to get a minimum viable cluster up
+ and running. By design, it cares only about bootstrapping, not about
+ provisioning machines. Likewise, installing various nice-to-have addons,
+ like the Kubernetes Dashboard, monitoring solutions, and cloud-specific
+ addons, is not in scope.
+
+ Instead, we expect higher-level and more tailored tooling to be built on
+ top of kubeadm, and ideally, using kubeadm as the basis of all deployments
+ will make it easier to create conformant clusters.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kubernetes/kubernetes</remote-id>
+ </upstream>
+</pkgmetadata>