summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-07-18 13:44:32 -0400
committerKenton Groombridge <concord@gentoo.org>2023-07-18 14:05:45 -0400
commit2f10b2a6c7e9b38196b5509c85822aea800ae21c (patch)
tree9bfbcf3018f5e7eabc0adffadc625eebb4aedff9 /sys-cluster/kubelogin/kubelogin-1.28.0.ebuild
parentwww-apps/miniflux: drop 2.0.43-r1 (diff)
downloadgentoo-2f10b2a6c7e9b38196b5509c85822aea800ae21c.tar.gz
gentoo-2f10b2a6c7e9b38196b5509c85822aea800ae21c.tar.bz2
gentoo-2f10b2a6c7e9b38196b5509c85822aea800ae21c.zip
sys-cluster/kubelogin: add 1.28.0
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-cluster/kubelogin/kubelogin-1.28.0.ebuild')
-rw-r--r--sys-cluster/kubelogin/kubelogin-1.28.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/kubelogin/kubelogin-1.28.0.ebuild b/sys-cluster/kubelogin/kubelogin-1.28.0.ebuild
new file mode 100644
index 000000000000..5d38e4717f8f
--- /dev/null
+++ b/sys-cluster/kubelogin/kubelogin-1.28.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="kubectl plugin for Kubernetes OpenID Connect authentication"
+HOMEPAGE="https://github.com/int128/kubelogin"
+SRC_URI="https://github.com/int128/kubelogin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -ldflags="-s -w" -o ./bin/${PN} .
+}
+
+src_install() {
+ newbin bin/${PN} "kubectl-oidc_login"
+ bin/${PN} completion bash > ${PN}.bash || die
+ bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}