summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-06-20 18:13:17 -0400
committerKenton Groombridge <concord@gentoo.org>2024-06-20 18:22:51 -0400
commit19bffd6555244cf75ea315ccf7622893866e7d32 (patch)
tree76701c366220672a6ebf5440dff9b81a99dd8c15 /sys-cluster/kubelogin/kubelogin-1.28.1.ebuild
parentsys-cluster/flux: drop 2.2.2 (diff)
downloadgentoo-19bffd6555244cf75ea315ccf7622893866e7d32.tar.gz
gentoo-19bffd6555244cf75ea315ccf7622893866e7d32.tar.bz2
gentoo-19bffd6555244cf75ea315ccf7622893866e7d32.zip
sys-cluster/kubelogin: add 1.28.1
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-cluster/kubelogin/kubelogin-1.28.1.ebuild')
-rw-r--r--sys-cluster/kubelogin/kubelogin-1.28.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/kubelogin/kubelogin-1.28.1.ebuild b/sys-cluster/kubelogin/kubelogin-1.28.1.ebuild
new file mode 100644
index 000000000000..3df1f523fb01
--- /dev/null
+++ b/sys-cluster/kubelogin/kubelogin-1.28.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="kubectl plugin for Kubernetes OpenID Connect authentication"
+HOMEPAGE="https://github.com/int128/kubelogin"
+SRC_URI="https://github.com/int128/kubelogin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_compile() {
+ ego build -ldflags="-s -w" -o ./bin/${PN} .
+}
+
+src_install() {
+ newbin bin/${PN} "kubectl-oidc_login"
+ bin/${PN} completion bash > ${PN}.bash || die
+ bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}