summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-07-10 22:51:04 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-07-10 22:51:04 +0300
commitd87f1d477348ceb11256ee2a41938cafa8885167 (patch)
tree5023c54fdf3d4f4e35a715245d30af0b89d5e977 /sys-cluster/rdma-core
parentsys-cluster/rdma-core: Drop old (diff)
downloadgentoo-d87f1d477348ceb11256ee2a41938cafa8885167.tar.gz
gentoo-d87f1d477348ceb11256ee2a41938cafa8885167.tar.bz2
gentoo-d87f1d477348ceb11256ee2a41938cafa8885167.zip
sys-cluster/rdma-core: migrate from cmake-utils
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster/rdma-core')
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild6
6 files changed, 18 insertions, 18 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild b/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild
index ae773c23dc32..6357c1b6ab13 100644
--- a/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -84,11 +84,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
diff --git a/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild b/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild
index 720b47023aef..c144274801ec 100644
--- a/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -84,11 +84,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
diff --git a/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild b/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild
index 9911097e9b41..06f727171cc0 100644
--- a/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -84,11 +84,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
diff --git a/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild
index be7204ccc11c..8d5f9b4caaa6 100644
--- a/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -84,11 +84,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
diff --git a/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
index be7204ccc11c..8d5f9b4caaa6 100644
--- a/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -84,11 +84,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index 6db92b4ee104..97ce36421f75 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -82,11 +82,11 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die