summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-24 17:54:16 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-24 19:07:46 +0200
commit422a92dcaaf3c892865f744ce9c1de22e797a1c6 (patch)
treebf06543632edf9aa56b8761ce0766de2deb79b3a /sys-cluster/singularity
parentdev-python/pyopencl: bump to 2020.2.1 (diff)
downloadgentoo-422a92dcaaf3c892865f744ce9c1de22e797a1c6.tar.gz
gentoo-422a92dcaaf3c892865f744ce9c1de22e797a1c6.tar.bz2
gentoo-422a92dcaaf3c892865f744ce9c1de22e797a1c6.zip
sys-cluster/singularity: bump to 3.6.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.6.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 92b34c1c6a62..6c8131d5a0ed 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1 +1,2 @@
DIST singularity-3.6.0.tar.gz 6169388 BLAKE2B ea07da3d586a96625a1016f9b4aa6b99072c89393dcb7c80aab624807e51fc107eee2629020bf3e1c19d6103544b63aad960d2ac27804fa6e03323a806fdf270 SHA512 695f3b4c1bd8cc4049fc3e8e296b369f5aadcd6b4717521b9aca68d997fd8a8c0bf349a2851c31b8a22f37fa010b4c7b93562fd6ac24cdc9699230a182f36d29
+DIST singularity-3.6.1.tar.gz 6170806 BLAKE2B fa92bf4df3c2a4ab4345ab0022862f19dde240d7275a79c8433164f02bc495f33d44e4c63b39b9bd3de60361e49fec3f2d258a3bafaadeba34b5d4a7cd3f514e SHA512 3037a14fec086e17b42ee8306624af39fd87c80821c73e0e1ab3d8a717dbdad86237f042d97c6a7870fc6beeced67d6cd52c8e445c41c39cdab7ccce1ce6adb5
diff --git a/sys-cluster/singularity/singularity-3.6.1.ebuild b/sys-cluster/singularity/singularity-3.6.1.ebuild
new file mode 100644
index 000000000000..202258ead7a6
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.6.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}