summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-25 12:34:29 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-25 12:37:15 +0200
commit8796bc16d8ed9fa2788ee79b1bb7cf274d91a314 (patch)
tree47d2e799bb42a064afa5785e148dc12cd2e2a4a1 /sys-cluster/sx/sx-2.0.ebuild
parentnet-misc/libres3: Remove last-rited pkg (diff)
downloadgentoo-8796bc16d8ed9fa2788ee79b1bb7cf274d91a314.tar.gz
gentoo-8796bc16d8ed9fa2788ee79b1bb7cf274d91a314.tar.bz2
gentoo-8796bc16d8ed9fa2788ee79b1bb7cf274d91a314.zip
sys-cluster/sx: Remove last-rited pkg
Diffstat (limited to 'sys-cluster/sx/sx-2.0.ebuild')
-rw-r--r--sys-cluster/sx/sx-2.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sys-cluster/sx/sx-2.0.ebuild b/sys-cluster/sx/sx-2.0.ebuild
deleted file mode 100644
index 5be2ed5769b2..000000000000
--- a/sys-cluster/sx/sx-2.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="Skylable SX - a distributed object-storage software for data clusters"
-HOMEPAGE="http://www.skylable.com/products/sx"
-SRC_URI="http://cdn.skylable.com/source/${P}.tar.gz"
-LICENSE="GPL-2 LGPL-2.1"
-# If a package appears that links against another .so apart from sxclient-2.0.0.so, change the subslot accordingly.
-SLOT="0/2"
-KEYWORDS="~amd64"
-IUSE="+client ipv6 +server ssl"
-nginx_modules_use="nginx_modules_http_fastcgi(-),nginx_modules_http_gzip(-),nginx_modules_http_proxy(-),nginx_modules_http_scgi(-),nginx_modules_http_uwsgi(-)"
-DEPEND="
- dev-libs/libltdl:0
- dev-libs/yajl
- net-misc/curl[idn,ipv6(-)?,ssh,ssl(-)?]
- server? ( >=dev-db/sqlite-3.8.4.3:3
- dev-libs/fcgi
- www-servers/nginx:mainline[http,ipv6(-)?,${nginx_modules_use},ssl(-)?] )
-"
-RDEPEND="${DEPEND}"
-
-# The server build depends on tools only built during client build.
-# The client, though, is fully functional without server components
-# (for remote access, for example).
-# Deactivate both only if you know you need *only* the libs.
-REQUIRED_USE="server? ( client )"
-
-# tests make a temporary install relative to $prefix, so docdir must be relative to it as well
-src_configure() {
- econf --disable-sxhttpd \
- --with-system-libs \
- --docdir="\${prefix}/usr/share/doc/${PF}" \
- $(use_enable client sxclient) \
- $(use_enable server)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- prune_libtool_files --all
-}