summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2019-04-04 21:40:19 -0400
committerPatrice Clement <monsieurp@gentoo.org>2019-04-09 14:05:58 +0200
commitb5c0098f78f050d3dac7cb8d96f81ee367b39f12 (patch)
treeb309f5ea004331a41befed60631aa92b6b1b3305 /sys-cluster/teleport
parentapp-editors/vim: vim-pager needs -minimal. (diff)
downloadgentoo-b5c0098f78f050d3dac7cb8d96f81ee367b39f12.tar.gz
gentoo-b5c0098f78f050d3dac7cb8d96f81ee367b39f12.tar.bz2
gentoo-b5c0098f78f050d3dac7cb8d96f81ee367b39f12.zip
sys-cluster/teleport: add v3.2.0.
Signed-off-by: Graeme Lawes <graemelawes@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11593 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-3.2.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index f7e6989ca4db..2bfa712d7d45 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -2,3 +2,4 @@ DIST teleport-2.6.7.tar.gz 16655508 BLAKE2B a020ab999b7503cb7aec54ed81532baf9d08
DIST teleport-2.7.1.tar.gz 18222601 BLAKE2B 86852a1c7f0b083d8fc46bb2e51e287f0d54ca8bd1a6306e21ad325b6f1487682f853eb313a1f6f6fc4dc4d25d93e909ed65dad6d00eb37f878904d6df30f98c SHA512 703056eb99aa91062c8d9cfa7852e3573c8968ce9dea0ff5b076d5225caf8d67b965948a47785cdc7e4341993ef3ed005677859d37653f7d22c05cb2db51efd7
DIST teleport-3.0.0.tar.gz 22365657 BLAKE2B a9cfec07ec73970b1050c51819ef4820be95fcd94dce0ffbb62deca38af28a944929c83a9ed2b443a93eb21f55d0cac024b66acf81c5d6939ba8e6b6ba40438a SHA512 8cba0b7471bebe9cdac07b44f17c99b7b323061f310ef0e61a3ebe1c4ea2ca2b1c853177528c4725a83366406e8b1a5aba23ecdd5fba7290bd6cab74ada3340d
DIST teleport-3.0.1.tar.gz 22365638 BLAKE2B 200d7612a56520607f7c157a4e1ff095f8621c2495cef520ce4db7b75f61346e7e5588ca8c9a9b9aa30b87d692c05d488343c3c7b1d30a46e90cacef42ed4172 SHA512 9a477ad174f0d7b0179cb4063731ebf0bd7cf31af22fb6db350b12839bfcdc9c8b68847bc33639546bf6b9026ee62ceb3197176f81a36d67f6b070f2eb4d65e1
+DIST teleport-3.2.0.tar.gz 22613098 BLAKE2B 0ff9675a071f5fb660ad4a7b0e085b9bec01c3d0967bdd206ce29a51addae545c4b2621854cbffdc0f76d0cbc6e5ec8f39e082b80b26ba13d352b1add199c965 SHA512 a3fdb520a62361f78632ac1680f86f183a533e47696791586b3c5ff7d505eb167a881c438c6a3dd72395140c521c065c8d8e4b93b5b8c9cbf134688dd8c1f8da
diff --git a/sys-cluster/teleport/teleport-3.2.0.ebuild b/sys-cluster/teleport/teleport-3.2.0.ebuild
new file mode 100644
index 000000000000..3fb8ff680c04
--- /dev/null
+++ b/sys-cluster/teleport/teleport-3.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build systemd
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE="pam"
+LICENSE="Apache-2.0"
+RESTRICT="test strip"
+SLOT="0"
+
+DEPEND="app-arch/zip"
+RDEPEND="pam? ( sys-libs/pam )"
+
+src_compile() {
+ BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.yaml ${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}