summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-14 11:54:20 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-14 11:54:42 +0200
commitb0315a1c158e7d652da3d55da025e7f33df82b99 (patch)
tree5e7a38b87aff4d7dd469c64bff5b9b6b8b9fae8c /sys-cluster/torque
parentsci-visualization/gnuplot: stable 5.2.6 for ia64, bug #689718 (diff)
downloadgentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.tar.gz
gentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.tar.bz2
gentoo-b0315a1c158e7d652da3d55da025e7f33df82b99.zip
sys-cluster/torque: avoid unneeded openssl dependency
Fixes: https://bugs.gentoo.org/677736 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/files/torque-6.0.4-no-openssl.patch60
-rw-r--r--sys-cluster/torque/torque-6.0.4-r1.ebuild178
2 files changed, 238 insertions, 0 deletions
diff --git a/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch b/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch
new file mode 100644
index 000000000000..3b7e3cd49188
--- /dev/null
+++ b/sys-cluster/torque/files/torque-6.0.4-no-openssl.patch
@@ -0,0 +1,60 @@
+From 840bee84bff9529f2f7de4293cf7d5f567985123 Mon Sep 17 00:00:00 2001
+From: Matt Ezell <ezellma@ornl.gov>
+Date: Thu, 8 Oct 2015 15:32:30 -0400
+Subject: [PATCH] Remove unnecessary dependency on openssl-devel
+
+Closes #219
+---
+ README.building_40 | 3 ---
+ configure.ac | 10 ----------
+ src/daemon_client/Makefile.am | 2 +-
+ 3 files changed, 1 insertion(+), 14 deletions(-)
+
+diff --git a/README.building_40 b/README.building_40
+index bd2af03070..4b3a8c5f8a 100644
+--- a/README.building_40
++++ b/README.building_40
+@@ -14,9 +14,6 @@ automake
+ libtool
+ pkg-config
+
+-Non-standard packages required for building the source:
+-libssl-dev (name may vary among OSes)
+-
+ *** For admins that use cpusets in any form ***
+ hwloc version 1.1 or greater is now required for building TORQUE with cpusets, as pbs_mom now uses the
+ hwloc API to create the cpusets instead of creating them manually.
+diff --git a/configure.ac b/configure.ac
+index 14f238a519..636575c1b4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -745,16 +745,6 @@ AC_CHECK_LIB(pthread, pthread_create,
+ LIBS="$LIBS $PTHREAD_LIBS"
+
+
+-dnl we need -lssl and -lcrypto, lets make sure they exist
+-AC_CHECK_LIB(ssl, SSL_accept,
+- [],
+- [AC_MSG_ERROR([TORQUE needs lib openssl-devel in order to build]) ])
+-AC_CHECK_LIB(crypto, BN_init,
+- [],
+- [AC_MSG_ERROR([TORQUE needs lib crypto (often openssl-devel) in order to build]) ])
+-
+-
+-
+ dnl
+ dnl we need libxml2
+ dnl
+diff --git a/src/daemon_client/Makefile.am b/src/daemon_client/Makefile.am
+index e39f5e70b2..fe9d592b06 100644
+--- a/src/daemon_client/Makefile.am
++++ b/src/daemon_client/Makefile.am
+@@ -5,7 +5,7 @@ CLEANFILES = *.gcda *.gcno *.gcov
+
+ include_HEADERS = trq_auth_daemon.h
+
+-AM_CFLAGS = -DPBS_SERVER_HOME=\"$(PBS_SERVER_HOME)\" -Wall -pthread -ldl -lrt -lssl -lcrypto
++AM_CFLAGS = -DPBS_SERVER_HOME=\"$(PBS_SERVER_HOME)\" -Wall -pthread -ldl -lrt
+
+ sbin_PROGRAMS = trqauthd
+
diff --git a/sys-cluster/torque/torque-6.0.4-r1.ebuild b/sys-cluster/torque/torque-6.0.4-r1.ebuild
new file mode 100644
index 000000000000..4cfac4df5ce4
--- /dev/null
+++ b/sys-cluster/torque/torque-6.0.4-r1.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic linux-info
+
+DESCRIPTION="Resource manager and queuing system based on OpenPBS"
+HOMEPAGE="http://www.adaptivecomputing.com/products/open-source/torque"
+SRC_URI="https://github.com/adaptivecomputing/torque/archive/6a0b37f85c7d644e9217cbab1542792d646f59a6.tar.gz -> ${P}-gh-20170829.tar.gz"
+
+LICENSE="torque-2.5"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="autorun cgroups cpusets +crypt doc drmaa kernel_linux libressl munge nvidia quickcommit server +syslog tk"
+
+DEPEND_COMMON="
+ sys-libs/zlib
+ sys-libs/readline:0=
+ dev-libs/libxml2
+ >=dev-libs/boost-1.41
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ cpusets? ( sys-apps/hwloc )
+ munge? ( sys-auth/munge )
+ nvidia? ( >=x11-drivers/nvidia-drivers-275 )
+ tk? (
+ dev-lang/tk:0=
+ dev-lang/tcl:0=
+ )
+ syslog? ( virtual/logger )
+ !!games-util/qstat"
+
+# libncurses.so is only needed for configure check on readline
+DEPEND="${DEPEND_COMMON}
+ sys-libs/ncurses:*
+ !!sys-cluster/slurm"
+
+RDEPEND="${DEPEND_COMMON}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !dev-libs/uthash"
+
+# Torque should depend on dev-libs/uthash but that's pretty much impossible
+# to patch in as they ship with a broken configure such that files referenced
+# by the configure.ac and Makefile.am are missing.
+# http://www.supercluster.org/pipermail/torquedev/2014-October/004773.html
+
+S="${WORKDIR}"/${PN}-6a0b37f85c7d644e9217cbab1542792d646f59a6
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.3-fix-emptystring-comparison.patch
+ "${FILESDIR}"/${P}-no-openssl.patch
+)
+
+pkg_setup() {
+ PBS_SERVER_HOME="${PBS_SERVER_HOME:-/var/spool/${PN}}"
+
+ # Find a Torque server to use. Check environment, then
+ # current setup (if any), and fall back on current hostname.
+ if [ -z "${PBS_SERVER_NAME}" ]; then
+ if [ -f "${ROOT}${PBS_SERVER_HOME}/server_name" ]; then
+ PBS_SERVER_NAME="$(<${ROOT}${PBS_SERVER_HOME}/server_name)"
+ else
+ PBS_SERVER_NAME=$(hostname -f)
+ fi
+ fi
+
+ if use cpusets || use cgroups; then
+ if ! use kernel_linux; then
+ einfo
+ elog " Torque currently only has support for cpusets and cgroups in linux."
+ elog "Assuming you didn't really want this USE flag and ignoring its state."
+ einfo
+ else
+ linux-info_pkg_setup
+ if ! linux_config_exists || ! linux_chkconfig_present CPUSETS; then
+ einfo
+ elog " Torque support for cpusets will require that you recompile"
+ elog "your kernel with CONFIG_CPUSETS enabled."
+ einfo
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ # We install to a valid location, no need to muck with ld.so.conf
+ # --without-loadlibfile is supposed to do this for us...
+ sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tk gui) \
+ $(use_enable tk tcl-qstat) \
+ $(use_enable syslog) \
+ $(use_enable server) \
+ $(use_enable drmaa) \
+ $(use_enable munge munge-auth) \
+ $(use_enable nvidia nvidia-gpus) \
+ $(usex crypt "--with-rcp=scp" "--with-rcp=mom_rcp") \
+ $(usex kernel_linux $(use_enable cpusets cpuset) --disable-cpuset) \
+ $(usex kernel_linux $(use_enable cpusets geometry-request) --disable-geometry-request) \
+ $(usex kernel_linux $(use_enable cgroups) --disable-cgroups) \
+ $(use_enable autorun) \
+ $(use_enable quickcommit) \
+ --with-server-home=${PBS_SERVER_HOME} \
+ --with-environ=/etc/pbs_environment \
+ --with-default-server=${PBS_SERVER_NAME} \
+ --disable-gcc-warnings \
+ --disable-silent-rules \
+ --with-tcp-retry-limit=2 \
+ --without-loadlibfile
+}
+
+src_install() {
+ local dir
+
+ DOCS=( CHANGELOG README.* Release_Notes )
+ use doc && DOCS+=( doc/admin_guide.ps doc/*.pdf )
+
+ default
+
+ # The build script isn't alternative install location friendly,
+ # So we have to fix some hard-coded paths in tclIndex for xpbs* to work
+ for file in $(find "${ED}" -iname tclIndex); do
+ sed \
+ -e "s/${ED//\// }/ /" \
+ -i "${file}" || die
+ done
+
+ for dir in $(find "${ED}/${PBS_SERVER_HOME}" -type d); do
+ keepdir "${dir#${ED}}"
+ done
+
+ if use server; then
+ newinitd "${FILESDIR}"/pbs_server-init.d-munge pbs_server
+ newinitd "${FILESDIR}"/pbs_sched-init.d pbs_sched
+ fi
+ newinitd "${FILESDIR}"/pbs_mom-init.d-munge pbs_mom
+ newconfd "${FILESDIR}"/${PN}-conf.d-munge ${PN}
+ newinitd "${FILESDIR}"/trqauthd-init.d trqauthd
+ newenvd "${FILESDIR}"/${PN}-env.d 25${PN}
+}
+
+pkg_preinst() {
+ if [[ -f "${ROOT}etc/pbs_environment" ]]; then
+ cp "${ROOT}etc/pbs_environment" "${ED}"/etc/pbs_environment || die
+ fi
+
+ if use server && [[ -f "${ROOT}${PBS_SERVER_HOME}/server_priv/nodes" ]]; then
+ cp \
+ "${EROOT}${PBS_SERVER_HOME}/server_priv/nodes" \
+ "${ED}/${PBS_SERVER_HOME}/server_priv/nodes" || die
+ fi
+
+ echo "${PBS_SERVER_NAME}" > "${ED}${PBS_SERVER_HOME}/server_name" || die
+
+ # Fix up the env.d file to use our set server home.
+ sed \
+ -e "s:/var/spool/${PN}:${PBS_SERVER_HOME}:g" \
+ -i "${ED}"/etc/env.d/25${PN} || die
+
+ if use munge; then
+ sed -i 's,\(PBS_USE_MUNGE=\).*,\11,' "${ED}"/etc/conf.d/${PN} || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "If this is the first time torque has been installed, then you are not"
+ elog "ready to start the server. Please refer to the documentation located at:"
+ elog "http://docs.adaptivecomputing.com/torque/${PN//./-}/adminGuide/help.htm#topics/torque/1-installConfig/initializeConfigOnServer.htm"
+ fi
+}