summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2017-04-25 11:28:26 +0200
committerUltrabug <ultrabug@gentoo.org>2017-04-25 11:28:45 +0200
commit4f7b8a6abd44eb279325db71b92799bbc8437a86 (patch)
tree2b93b150a35b67c759a73386d3dc07131b68aa11 /sys-cluster
parentx11-libs/libQGLViewer: remove old (diff)
downloadgentoo-4f7b8a6abd44eb279325db71b92799bbc8437a86.tar.gz
gentoo-4f7b8a6abd44eb279325db71b92799bbc8437a86.tar.bz2
gentoo-4f7b8a6abd44eb279325db71b92799bbc8437a86.zip
sys-cluster/pacemaker: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pacemaker/Manifest1
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.16.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-cluster/pacemaker/Manifest b/sys-cluster/pacemaker/Manifest
index 64d198721488..3897785ab98d 100644
--- a/sys-cluster/pacemaker/Manifest
+++ b/sys-cluster/pacemaker/Manifest
@@ -1,2 +1,3 @@
DIST Pacemaker-1.1.12.tar.gz 10459675 SHA256 f5c72b609fac18d362880d120f08f990e8afd9388e6ff86c55cd93900ba54d9c SHA512 cf88a313f5e91f445a159a5d800d27fd891f63c082c92d3f09bfd2aff856325e8ef6e0ebab8c0b2b9cd6eb15cc593c58c8e23e888e17d5286ebc651dd096f9c1 WHIRLPOOL e737d70288936d2f76d310848940bde78537c32e703c68d8dd37a78e54a66dc9d34cf2fe0037f1621fbc5ba10bb9688490da96394cde65f0668d4b62eccf3f03
DIST Pacemaker-1.1.14.tar.gz 4729808 SHA256 2f73043a5de5e66a47462d37cd68c4c6861f71a03c0ea02eb4ae2b1a550cd7b0 SHA512 81927061bcc0a0b88c472f87a2cbdb26b88a2443b06112cd8c8d58d8491da4e9ae03997108c9d40aa408e80e2998bdc0ac03691f1732d2629c4cef0adcc4b7fa WHIRLPOOL cbae34051a406a9379157fe13171ea8b04c9793528c5f346a7845b2ffa894df4a74fd008e708d99207c6064acf2a39bf569dff0200c47552c0b3b124de00e7eb
+DIST Pacemaker-1.1.16.tar.gz 4897772 SHA256 dffcae035975669a66ab545d45216a637496a251ee2114fa03d58acfcc969202 SHA512 967c860fab7b9e73dd8643e6d09083a2a1298a77d71c3b138187803c89153bee7219da13e6b94b20f2881b53ba7fc1c8584a43ff058a265e76708fd5dbccf534 WHIRLPOOL 8beb0188968743d6415c7158790582f01192a643a13246e61cafd6eb8e0d22cd2565dd31e5cfcda04b3aa3e9c749b4c1f0c44bd9419c3fffcc815909e836a92f
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.16.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.16.ebuild
new file mode 100644
index 000000000000..e746e5d0bca4
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-1.1.16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1
+
+MY_PN="Pacemaker"
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+REQUIRED_USE="cman? ( !heartbeat )"
+IUSE="acl cman heartbeat smtp snmp static-libs"
+
+DEPEND="${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-cluster/cluster-glue
+ >=sys-cluster/libqb-0.14.0
+ sys-cluster/resource-agents
+ cman? ( sys-cluster/cman )
+ heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
+ !heartbeat? ( sys-cluster/corosync )
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ -ggdb//g" configure.ac || die
+ eautoreconf
+ python_fix_shebang .
+}
+
+src_configure() {
+ local myopts=""
+ if use heartbeat ; then
+ myopts="--without-corosync"
+ else
+ myopts="--with-ais"
+ fi
+ # appends lib to localstatedir automatically
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ $(use_with acl) \
+ $(use_with cman cs-quorum) \
+ $(use_with cman cman) \
+ $(use_with heartbeat) \
+ $(use_with smtp esmtp) \
+ $(use_with snmp) \
+ $(use_enable static-libs static) \
+ ${myopts}
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/var/run "${D}"/etc/init.d
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ if has_version "<sys-cluster/corosync-2.0"; then
+ insinto /etc/corosync/service.d
+ newins "${FILESDIR}/${PN}.service" ${PN} || die
+ fi
+}